pta甲级1001 A+B Format(AC)

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

结尾无空行

Sample Output:

-999,991

思路:
难度不大,分一下和为正为负即可。

#include<bits/stdc++.h>
using namespace std;
int main()
{
	long long int a,b,c,sum;
	cin>>a>>b;
	c=a+b;
	char str[100];
	if(c>=0) sum=c;
	else if(c<0) sum=c*(-1);
	sprintf(str,"%ld",sum);
	if(c<0) printf("-");
	int m=strlen(str);
	for(int i=0;i<m;i++)
	{
		if((m-i)%3==0&&i!=0) printf(",");
		printf("%c",str[i]);
	}
	return 0;
}

 

 

搞定!


从今天开始,每天一道甲级和乙级,虽然很多数据结构的知识还没有学,但是编程不就是在过程中遇到不会然后查找学会嘛。 

  • 6
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值