PTA甲级1001 A+B Format

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​ ≤a,b≤10​6. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

解题方法

方法一(我的第一反应)

注意点
  1. 循环输入 运行超时
  2. 是每三个数字一个“,”,例:1,000,000、1,000
  3. 有些方法要注意0
#include <stdio.h>
int main()
{
	int a = 0, b = 0, c = 0, i = 0, n = 0;
	int s[100] = { '0' };
	scanf("%d %d", &a, &b);
		c = a + b;
		if (c != 0) {
			if (c < 0) {
				c = -c;
				printf("-");
			}
			for (i = 0; c != 0; i++) {
				s[i] = c % 10;
				c = c / 10;
			}
			i--;
			if (i < 3)
			{
				for (i; i >= 0; i--) {
					printf("%d", s[i]);
				}
			}
			else if (i <= 5)
			{
				n = i;
				for (i; i >= 0; i--) {
					if (i == 2) {
						printf(",");
					}
					printf("%d", s[i]);
				}
			}
			else
			{
				n = i;
				for (i; i >= 0; i--) {
					if (i == 2 || i == 5) {
						printf(",");
					}
					printf("%d", s[i]);
				}
			}

		}
		else if (c == 0)
		{
			printf("0");
		}
}

方法二(网上看到的)

注意点
  1. 0的输出个数,将逗号后面的%d改成%03d。
#include <stdio.h>

int main()
{
	int a = 0, b = 0, c = 0, i = 0, n = 0;
	int s[100] = { '0' };
	scanf("%d %d", &a, &b);
		c = a + b;
		if (c < 0) {
			c = -c;
			printf("-");
		}
		if (c < 1000) {
			printf("%d", c);
		}
		else if (c >= 1000 && c < 1000000)  {
			printf("%d,%03d", c / 1000,c%1000);
		}
		else
		{
			printf("%d,%03d,%03d", c / 1000000, c % 1000000/1000,c%1000);
		}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值