pta甲级1005 Spell It Right(AC)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

结尾无空行

Sample Output:

one five

结尾无空行

思路:
1.先输入一组字符串。代表数字N。

2.将N的每一位加起来。

3.将求和得到的数字转为字符串类型。

4.用switch逐个判断每个位上分别是什么,输出答案。 

#include<bits/stdc++.h>
using namespace std;

int main()
{
	char str1[105],str2[105];
	int total=0,flag=0;
	cin>>str1;
	int len=strlen(str1);
	for(int i=0;i<len;i++){
		total+=str1[i]-'0';
	}
	sprintf(str2,"%d",total);
	int len2=strlen(str2);
	for(int i=0;i<len2;i++){
		if(flag==1) cout<<' ';
		switch(str2[i]){
			case '0': cout<<"zero"; break;
			case '1': cout<<"one"; break;
			case '2': cout<<"two"; break;
			case '3': cout<<"three"; break;
			case '4': cout<<"four"; break;
			case '5': cout<<"five"; break;
			case '6': cout<<"six"; break;
			case '7': cout<<"seven"; break;
			case '8': cout<<"eight"; break;
			case '9': cout<<"nine"; break;
		}
		flag=1;
	}
}

 

 

  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值