pta甲级1059 Prime Factors (AC)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1​k1​×p2​k2​×⋯×pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1​^k1​*p2​^k2​**pm​^km​, where pi​'s are prime factors of N in increasing order, and the exponent ki​ is the number of pi​ -- hence when there is only one pi​, ki​ is 1 and must NOT be printed out.

Sample Input:

97532468

结尾无空行

Sample Output:

97532468=2^2*11*17*101*1291

结尾无空行

思路:
1.先生成一个素数表

2.从素数表中找到符合条件的因子

#include<bits/stdc++.h>
using namespace std;

const int maxn=100010;

bool is_prime(int n)
{
	if(n==1) return false;
	int sqr=(int)sqrt(1.0*n);
	for(int i=2;i<=sqr;i++){
		if(n%i==0) return false;
	}
	return true;
}//判断是否为素数的函数 

int prime[maxn],num=0,pnum=0;

void Find_Prime()
{
	for(int i=1;i<maxn;i++){
		if(is_prime(i)==true) prime[pnum++]=i;
	}
}//建立素数表 

struct factor{
	int x,cnt;
}fac[10];

int main()
{
	Find_Prime();
    int n;
	cin>>n;
	int sqr=(int)sqrt(1.0*n);
	if(n==1) printf("1=1");
	else{
		cout<<n<<"=";
		for(int i=0;i<pnum&&prime[i]<=sqr;i++){
			fac[num].cnt=0;
			if(n%prime[i]==0){
				fac[num].x=prime[i];
				while(n%prime[i]==0){
					fac[num].cnt++;
					n/=prime[i];
			    }
			    num++;
	    	}
	    	if(n==1) break;
		}
		if(n!=1){
			fac[num].x=n;
			fac[num++].cnt=1;//这里num++很重要,保证前后的一致性,使输出数据的代码更加简便 
		}
		for(int i=0;i<num;i++){
				if(i>0) cout<<"*";
				cout<<fac[i].x;
				if(fac[i].cnt!=1) cout<<"^"<<fac[i].cnt;
		}
	}	
	return 0;
}

 搞定了!

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值