【java】二分查找 求下界 求上界

二分查找要求数组必须是有序数组,输入数组长度n以及查找元素值key,然后输入n个元素,输出key所在的位置,不存在则输出-1.

样例输入:

8 23
1 4 14 23 55 66 77 88
4 6
1 4 7 8

样例输出:

3

-1

import java.util.Scanner;

public class Main {
	public static void main(String[] args){
		Scanner scanner = new Scanner(System.in);
		while(scanner.hasNext())
		{
			int n=scanner.nextInt();
			int key=scanner.nextInt();	//查找目标元素所在位置,没有返回-1
			int[] arr=new int[n];		//	数组必须是有序数组
			for(int i=0;i<n;i++){
				arr[i]=scanner.nextInt();
			}
			int x=0;
			int y=arr.length;
			int res=-1;
			while(x<y){
				int m=(x+y)/2;
				if(arr[m]==key){
					res=m;
					break;
				}else if(arr[m]>key){
					y=m;
				}else{
					x=m+1;
				}
			}
			System.out.println(res);
		}
		scanner.close();
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值