UVA_297 - Quadtrees

 Quadtrees 


A quadtree is a representation format used to encode images. The fundamental ideabehind the quadtree is that any image can be split into four quadrants. Each quadrant mayagain be split in four sub quadrants, etc. In the quadtree, the image is represented by aparent node, while the four quadrants are represented by four child nodes, in a predeterminedorder.

Of course, if the whole image is a single color, it can be represented by a quadtree consistingof a single node. In general, a quadrant needs only to be subdivided if it consists of pixels ofdifferent colors. As a result, the quadtree need not be of uniform depth.

A modern computer artist works with black-and-white images of tex2html_wrap_inline34 units, for a totalof 1024 pixels per image. One of the operations he performs is adding two images together,to form a new image. In the resulting image a pixel is black if it was black in at least one ofthe component images, otherwise it is white.

This particular artist believes in what he calls the preferred fullness:for an image to beinteresting (i.e. to sell for big bucks) the most important property is the number of filled(black) pixels in the image. So, before adding two images together, he would like to knowhow many pixels will be black in the resulting image. Your job is to write a program that,given the quadtree representation of two images, calculates the number of pixels that areblack in the image, which is the result of adding the two images together.

In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at thetop of the figure.


Input Specification


The first line of input specifies the number of test cases (N) your program has to process.

The input for each test case is two strings, each string on its own line. The string is thepre-order representation of a quadtree, in which the letter 'p' indicates a parent node, theletter 'f' (full) a black quadrant and the letter 'e' (empty) a white quadrant. It is guaranteedthat each string represents a valid quadtree, while the depth of the tree is not more than 5(because each pixel has only one color).

Output Specification


For each test case, print on one line the text 'There are X black pixels.', where X is the number of black pixels in the resulting image.

Example Input


3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe


Example Output


There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.


题意分析:

 32*32个格子可以代表1024个像素,一格子代表一个像素;四分树可以表示一个黑白图像,给定两颗四分树的先序遍历,按照题中规则,统计黑色像素的数量之和

解题思路:

1. 32*32共1024个格子,所以构建一个int image[32][32]的二维数组,然后按照给定的四分树,依次再image数组中填充(当为黑色时),边填充边统计;

2. 将给定的先序序列,按照题中1,2,34的位置依次递归填充,并统计。


代码如下:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;

const int MAXSIZE = 1024 + 10;
const int len = 32;
int image[len][len];
int cnt;//统计像素

void draw(string str, int& p, int r, int c, int w)
{
    char ch = str[p++];
    if(ch=='p')
    {
        draw(str,p,r,c+w/2,w/2);//1 填充
        draw(str,p,r,c,w/2);    //2 填充
        draw(str,p,r+w/2,c,w/2);//3 填充
        draw(str,p,r+w/2,c+w/2,w/2);//4 填充
    }
    else if(ch=='f'){
        for(int i=r;i<r+w;i++)
            for(int j=c;j<c+w;j++)
        if(image[i][j]==0) { image[i][j]=1;cnt++; }
    }
}

int main()
{
    //freopen("572.txt","r",stdin);
    int n;
    string str;
    cin>>n;
    while(n--)
    {
        memset(image,0,sizeof(image));
        cnt = 0;
        for(int i=0;i<2;i++) {
            cin>>str;
            int p=0;
            draw(str,p,0,0,len);
        }
        printf("There are %d black pixels.\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值