(HDU - 2298)Toxophily

(HDU - 2298)Toxophily

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2310 Accepted Submission(s): 1275

Problem Description

The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object’s coordinates, please calculate the angle between the arrow and x-axis at Bob’s point. Assume that g=9.8N/m.

Input

The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow’s exit speed.
Technical Specification

  1. T ≤ 100.
  2. 0 ≤ x, y, v ≤ 10000.

Output

For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output “-1”, if there’s no possible answer.

Please use radian as unit.

Sample Input

3
0.222018 23.901887 121.909183
39.096669 110.210922 20.270030
138.355025 2028.716904 25.079551

Sample Output

1.561582
-1
-1

题目大意:一个小球从(0,0)处与x轴正向呈一定角度θ以初速度v发射,目标物的坐标为(x,y),问这个角度存在吗?存在的话最小角度是多少?

思路:将小球速度分解为x轴方向和y轴方向,由物理学速度公式可得: vcosθt=x;vsinθt1/2gt2=y 联立二式,消去t可能方程(利用 cosθ2+sinθ2=1 gx2/(2v2)tanθ2xtanθ+gx2/(2v2)+y=0 .于是原题等价于方程③在区间[0,π/2]有无解,有解取最小解。

#include<cstdio>
#include<cmath>
using namespace std;

const double g=9.8;
const double pi=acos(-1.0);

int main()
{
    int T;
    double x,y,v;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf",&x,&y,&v);
        double a=(g*x*x)/(2*v*v),b=-x,c=(g*x*x)/(2*v*v)+y;
        double t=b*b-4*a*c;
        if(t<0)
        {
            printf("-1\n");
            continue;
        }
        double x1=(-b-sqrt(t))/(2*a),x2=(-b+sqrt(t))/(2*a);
        x1=atan(x1);
        x2=atan(x2);
        if(x1>=0&&x2<=pi/2) printf("%.6f\n",x1);
        else if(x1>=0&&x1<=pi/2&&x2>pi) printf("%.6f\n",x1);
        else if(x1>0&&x2>=0&&x2<=pi/2) printf("%.6f\n",x2);
        else printf("-1\n");
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值