(HDU - 3172)Virtual Friends

(HDU - 3172)Virtual Friends

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9552 Accepted Submission(s): 2784

Problem Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends’ friends, their friends’ friends’ friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person’s network.

Assume that every friendship is mutual. If Fred is Barney’s friend, then Barney is also Fred’s friend.

Input

Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma

Sample Output

2
3
4

题目大意:先给出n对人组成朋友网,没给出一对朋友就让你输出现在这对朋友的关系网里多少个人。

思路:每个人给出的是名字,我们可以利用map将string类型映射为int,从而这题题目就变成了并查集的模板题。
ps:这里的输入太坑了,要注意是多组多组数据没因为这个一直wa。具体看代码吧,无力吐槽。

#include<cstdio>
#include<iostream>
#include<string>
#include<map>
using namespace std;

const int maxn=100005;
int fa[maxn<<1],num[maxn<<1];

map<string,int> mp;

int find(int x)
{
    if(x==fa[x]) return x;
    else return fa[x]=find(fa[x]);
}

void merge(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        fa[fx]=fy;
        num[fy]+=num[fx];//合并的时候要将不同根网络的人数也合并起来 
    }
    printf("%d\n",num[fy]);
}

int main()
{
    int T;
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            mp.clear();
            int n;
            scanf("%d",&n);
            int cnt=0;
            for(int i=0;i<=n;i++)//初始化 
            {
                fa[i]=i;
                num[i]=1;
            }
            while(n--)
            {
                string a,b;
                cin>>a>>b;
                if(!mp.count(a)) mp[a]=cnt++;//没找到a 
                if(!mp.count(b)) mp[b]=cnt++;
                merge(mp[a],mp[b]);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值