【HDU - 3172】【 Virtual Friends 】

题目:

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input

Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest. 
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma

Sample Output

2
3
4

题意:虚拟网络,问当前我们输入的这两个人名所在集合的朋友的个数,如果之前各自属于不同的集合里,只要有两个人成为朋友,那么这两个集合的所有人都属于一个集合。且输出的是当前输入人名的所在圈子的朋友数目。

解题思路:并查集的升级操作,增加一个num数组 用来记录父节点下有多少子节点,然后必须用到map,将输入的人名转换为数字,之后就是并查集的正常操作。

需要注意的是,maxn要开的大一些,防止数组越界,然后就是merge函数内 num[pa]+=num[pb],因为pa作为了pb 的父节点,所以他的子节点就归到其父节点上了。

ac代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<map>
#include<cmath> 
#define maxn 200003
using namespace std;

int far[maxn];
int num[maxn];
int n,nnum;
int find(int x)
{
	if(x!=far[x])
		return far[x]=find(far[x]);
	return far[x];
 } 

void merge(int a,int b)
{
	int pa=find(a);
	int pb=find(b);
	if(pa!=pb)
	{
		num[pa]+=num[pb];
		far[pb]=pa;
	}
}
void init()
{
	for(int i=1;i<maxn+10;i++)
	{
		far[i]=i;	
		num[i]=1;
	}
	
}
int main()
{
	int t;
	while(scanf("%d",&t)!=EOF)
	{		
		while(t--)
		{
			init();
			nnum=1;
			scanf("%d",&n);	
			map	<string ,int > mp;
			while(n--)
			{
				char str1[22],str2[22];
				scanf("%s %s",str1,str2);
				if(mp.find(str1)==mp.end())
					mp[str1]=nnum++;
				if(mp.find(str2)==mp.end())
					mp[str2]=nnum++;
				merge(mp[str1],mp[str2]);
				int rt=find(mp[str1]);
				printf("%d\n",num[rt]);
			}
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值