(POJ - 1068)Parencodings

(POJ - 1068)Parencodings

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27100 Accepted: 15916

Description

Let S = s1 s2…s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2…pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2…wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S       (((()()())))

P-sequence      4 5 6666

W-sequence      1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

题目大意:对于一个合法括号序列s,p序列表示每一个右括号左边有几个左括号,w序列表示与右括号匹配的是第几个左括号。先给出p序列要求w序列。

思路:根据所给出的p序列先还原出s序列,再求w序列。用0原序列中的左括号,1表示原序列中的右括号,2表示已经与括号好匹配过了的左括号。具体见代码。

#include<cstdio>
#include<cstring>
using namespace std;

const int maxn=25;
int s[maxn<<1],p[maxn],w[maxn],right[maxn];
//s表示原先序列,right表示右括号的位置 
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(s,0,sizeof(s));//0表示左括号,1表示右括号 
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++) 
        {
            scanf("%d",p+i);
            if(i==1) right[i]=p[i]+1;
            else right[i]=right[i-1]+p[i]-p[i-1]+1;
            s[right[i]]=1;
        }
        for(int i=1;i<=n;i++)
            for(int j=right[i];j>=1;j--)
                if(s[j]==0)
                {
                    s[j]=2;//2表示已经与右括号匹配过的左括号 
                    int cnt=0;
                    for(int k=right[i];k>j;k--) 
                        if(s[k]==2) cnt++; 
                    w[i]=cnt+1;
                    break;
                }
        for(int i=1;i<n;i++) printf("%d ",w[i]);
        printf("%d\n",w[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值