(UVA - 11995)I Can Guess the Data Structure!

9 篇文章 0 订阅

(UVA - 11995)I Can Guess the Data Structure!

There is a bag-like data structure, supporting two operations:
1 x Throw an element x into the bag.
2 Take out an element from the bag.
Given a sequence of operations with return values, you’re going to guess the data structure. It is a stack (Last-In, First-Out), a queue (First-In, First-Out), a priority-queue (Always take out larger elements first) or something else that you can hardly imagine!

Input

There are several test cases. Each test case begins with a line containing a single integer n (1 ≤ n ≤ 1000). Each of the next n lines is either a type-1 command, or an integer 2 followed by an integer x. That means after executing a type-2 command, we get an element x without error. The value of x is always a positive integer not larger than 100. The input is terminated by end-of-file (EOF).

Output

For each test case, output one of the following:
stack It’s definitely a stack. queue It’s definitely a queue. priority queue It’s definitely a priority queue. impossible It can’t be a stack, a queue or a priority queue. not sure It can be more than one of the three data structures mentioned above.

Sample Input

6
1 1
1 2
1 3
2 1
2 2
2 3
6
1 1
1 2
1 3
2 3
2 2
2 1
2
1 1
2 2
4
1 2
1 1
2 1
2 2
7
1 2
1 5
1 1
1 3
2 5
1 4
2 4

Sample Output

queue
not sure
impossible
stack
priority queue

题目大意:给出一系列操作,1代表拿入数据,2代表拿出数据,问这一系列操作是什么数据结构。

思路:直接用stack,queue,priority queue 模拟数据的进出。

#include<cstdio>
#include<stack>
#include<queue>
using namespace std;

const int maxn=1005;
int a[maxn],op[maxn];
int n;

bool check1()
{
    stack<int> st;
    for(int i=0;i<n;i++)
    {
        if(op[i]==2)
        {
            if(st.empty()) return false;
            int tmp=st.top();
            st.pop();
            if(tmp!=a[i]) return false;
        }
        else st.push(a[i]);
    }
    return true;
}

bool check2()
{
    queue<int> q;
    for(int i=0;i<n;i++)
    {
        if(op[i]==2)
        {
            if(q.empty()) return false;
            int tmp=q.front();
            q.pop();
            if(tmp!=a[i]) return false;
        }
        else q.push(a[i]);
    }
    return true;
}

bool check3()
{
    priority_queue<int> q;
    for(int i=0;i<n;i++)
    {
        if(op[i]==2)
        {
            if(q.empty()) return false;
            int tmp=q.top();
            q.pop();
            if(tmp!=a[i]) return false; 
        }
        else q.push(a[i]);
    }
    return true;
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++) scanf("%d%d",op+i,a+i);
        bool st=check1(),q=check2(),pq=check3();
        if(st&&!q&&!pq) printf("stack\n");
        else if(!st&&q&&!pq) printf("queue\n");
        else if(!st&&!q&&pq) printf("priority queue\n");
        else if(!st&&!q&&!pq) printf("impossible\n");
        else printf("not sure\n");
    }
    return 0; 
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值