Hdu-5763 Another Meaning(DP+KMP)

96 篇文章 0 订阅
34 篇文章 0 订阅

Another Meaning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 558    Accepted Submission(s): 262


Problem Description
As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”.
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.
 

Sample Input
  
  
4 hehehe hehe woquxizaolehehe woquxizaole hehehehe hehe owoadiuhzgneninougur iehiehieh
 

Sample Output
 
 
Case #1: 3 Case #2: 2 Case #3: 5 Case #4: 1
Hint
In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”. In the third case, “hehehehe” can hav   题意:给你一个字符串a和字符串b,字符串b有两种解释,问你字符串a有几种解释。 分析:先作一遍KMP求出所有的匹配位置,然后做一遍DP,f[i]表示a的前i个字符组成的前缀有多少种解释,则f[i] = f[i-1],当i是一个匹配位置时,还要加上f[i-m].
#include <cstdio>
#include <stack>
#include <queue>    
#include <vector>    
#include <cstdio>    
#include <utility>    
#include <cstring>    
#include <iostream>    
#include <algorithm>    
#define INF 0x3f3f3f3f
#define MOD 1000000007
#define eps 1e-6
using namespace std;
int T,n,num,Next[100005],f[100005];
bool jud[100005];
char s[100005],s2[100005];
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s2);
        scanf("%s",s);
        int n = strlen(s2),m = strlen(s);
        memset(Next,0,sizeof(Next));
        memset(f,0,sizeof(f));
        memset(jud,0,sizeof(jud));
        int now = Next[0] = -1;
        for(int i = 1;i < m;i++)
        {
            while(now >= 0 && s[now+1] != s[i]) now = Next[now];
            if(s[now+1] == s[i]) now++;
            Next[i] = now;
        }
        now = -1;
        for(int i = 0;i < n;i++)
        {
            while(now >= 0 && s[now+1] != s2[i]) now = Next[now];
            if(s[now+1] == s2[i]) now++;
            if(now == m-1) 
            {
                jud[i+1] = 1;
                now = Next[now];
            }
        }
        f[0] = 1;
        for(int i = 1;i <= n;i++)
        {
            f[i] = f[i-1];
            if(jud[i]) f[i] = (f[i] + f[i-m]) % MOD;
        }
        printf("Case #%d: %d\n",++num,f[n]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值