1028. 人口普查(20)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:

3 Tom John



#include<stdio.h>

	struct people{
		char name[6];
		int year, month, day;
	}temp, oldest, youngest,left,right;

	
	bool leftlaw(people a, people b)
	{
		if (a.year != b.year) return a.year <= b.year;
		else if (a.month != b.month) return a.month <= b.month;
		else if (a.day != b.day) return a.day <= b.day;
	}

	bool rightlaw(people a, people b)
	{
		if (a.year != b.year) return a.year >= b.year;
		else if (a.month != b.month) return a.month >= b.month;
		else if (a.day != b.day) return a.day >= b.day;
	}
	void init(){
		youngest.year = left.year = 1814;
		oldest.year = right.year = 2014;
		youngest.month = oldest.month = left.month = right.month = 9;
		youngest.day = oldest.day = right.day = left.day = 6;
	}
	int main(){
		int n, i, step = 0;
		scanf("%d", &n);
		init();
	for (i = 0; i < n; i++)
	{
		scanf("%s %d/%d/%d", temp.name, &temp.year, &temp.month, &temp.day);
		if (leftlaw(temp, right) && rightlaw(temp, left))
		{
			step++;
			if (leftlaw(temp, oldest)) oldest = temp;
			if (rightlaw(temp, youngest)) youngest = temp;
		}
	}
	if (step == 0) printf("0\n");
	else printf("%d %s %s", step, oldest.name, youngest.name);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值