Given a positive integer n, print out the positions of all 1's in its binary representation. The position of the least significant bit is 0.
Example
The positions of 1's in the binary representation of 13 are 0, 2, 3.
Task
Write a program which for each data set:
reads a positive integer n,
computes the positions of 1's in the binary representation of n,
writes the result.
Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
Output
The output should consists of exactly d lines, one line for each data set.
Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.
Sample Input
1
13
Sample Output
0 2 3
题意:就是输入一个数像13,能找到数字使得13=2^0+2^2+2^3,把0,2,3输出。
思路:依次减去即可
注意:0,2,3要从小到大按顺序输出,所以要个排序
代码:
#include <stdio.h>
#include <math.h>
void paixu(int a[100],int n)
{
int t;
int i,j;
for(i=0;i<n;i++)
for(j=i;j<n;j++)
{
if(a[i]>a[j])
{
t=a[i];
a[i]=a[j];
a[j]=t;
}
}
}
int main()
{
int d;
int n;
int a[100]={0};
scanf("%d",&d);
while(d--){
int j=0;
int i=0;
scanf("%d",&n);
if(n%2==0)
{
while(n!=0)
{
if(pow(2,j)<=n&&pow(2,j+1)>n)
{
a[i++]=j;
n=n-pow(2,j);
j=0;
}
j++;
}
}
else
{
a[i++]=0;
n=n-1;
while(n!=0)
{
if(pow(2,j)<=n&&pow(2,j+1)>n)
{
a[i++]=j;
n=n-pow(2,j);
j=0;
}
j++;
}
}
paixu(a,i);
for(j=0;j<i;j++)
{
printf("%d",a[j]);
if(j!=i-1)
printf(" ");
else
printf("\n");
}
}
return 0;
}