ZOJ 1879 Jolly Jumpers

Jolly Jumpers

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.


Input

Each line of input contains an integer n < 3000 followed by n integers representing the sequence.


Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".


Sample Input

4 1 4 2 3
5 1 4 2 -1 6


Sample Output

Jolly
Not jolly

题意:首先题意是相邻2个数相减的数要包括1到n-1
思路:他们相减的t不能=0,不能超过N,而且相减的出的数字种类不可能有重复,若有重复则肯定1到N-1种
肯定有数字没包含。因为1到N-1有N-1个数,而且两两连续相减可减N-1次,两者等额。所以我们把已经出现的数字用b[t]来标记
代码:
#include <stdio.h>
#include <math.h>
#include <string.h>


int main()
{
    int N;
    int arr[3500];
    int b[3500];
    
    while(scanf("%d",&N)!=EOF)
    {
        int i,t,flag=1;
        memset(b,0, sizeof(b));
        for(i=0;i<N;i++)
            scanf("%d",&arr[i]);
        for(i=0;i<N-1;i++)
        {
            t=fabs(arr[i]-arr[i+1]);
            if(t&&t<N&&!b[t])
                b[t]=1;
            else
            {
                flag=0;
                printf("Not jolly\n");
                break;
            }
        }
        if(flag)
            printf("Jolly\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值