ZOJ 1871 Steps

Steps

Time Limit: 2 Seconds       Memory Limit: 65536 KB

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step. 

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.


Input

For each test case, a line follows with two integers: 0 <= x <= y < 2^31.


Output

For each test case, print a line giving the minimum number of steps to get from x to y.


Sample Input

45 48
45 49
45 50


Sample Output

3
3
4

题意:第一次和最后一次只能走1步,中间的步伐长度以1的长度递增或递减,如12321.
思路:找规律的题目,规律是步数为1的数有1个步数为2的数有1个,步数为3的数有2个,步数为4的数为2个,步数为5的数有3个,步数为6的数有3个
以此推下去数为1+1+2+2+3+3......如果这个数是第一次出现则步数为2*i-1,第2次出现为2*i
代码:
#include <stdio.h>


int main()
{
    int m,n;
    int i,j;
    while (scanf("%d%d",&m,&n)!=EOF) {
        int sum=0,flag=0;
        if(n-m==0)
        {
          printf("0\n");
            continue;
        }
        for(i=1;;i++)
        {
            for(j=0;j<2;j++)
            {
                sum+=i;
               if((n-m)<=sum)
               {
                   flag=1;
                   break;
               }
            }
            if(flag==1)
                break;
        }
        if(j==1)
            printf("%d\n",2*i);
        else
            printf("%d\n",2*i-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值