杭电 HDU 1548 A strange lift

http://acm.hdu.edu.cn/showproblem.php?pid=1548

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8225    Accepted Submission(s): 3127


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5 3 3 1 2 5 0
 

Sample Output
  
  
3
 

广搜(Bfs)题

AC代码:
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>

using namespace std;

struct Node
{
    int f;
    int i;
};

int floor[210];
int yn[210];

int Bfs(int n, int a, int b)
{
    Node now,next;
    queue<Node> q;
    now.f = a;
    now.i = 0;
    q.push(now);
    while(!q.empty())
    {
        now = q.front();
        q.pop();
        yn[now.f] = 2;   //标记此楼已经到达
 //       printf("%d %d\n",now.f,now.i);
        if(now.f == b)   //判断是否到达指定楼层
        {
            return now.i;
        }
        else
        {
            next.i = now.i+1;
            next.f = now.f+floor[now.f];   //向上走
            if(next.f > 0 && next.f <= 200 && yn[next.f] == 0)
            {
                yn[next.f] = 1;   //标记此楼
                q.push(next);
            }
            next.f = now.f-floor[now.f];   //向下走
            if(next.f > 0 && next.f <= 200 && yn[next.f] == 0)
            {
                yn[next.f] = 1;   //标记此楼
                q.push(next);
            }
        }
    }
    return -1;
}

int main()
{
    int n,a,b;
    int i,num;
    while(scanf("%d",&n)&&n)
    {
        memset(yn,0,sizeof(yn));
        for(i = 0; i< 210; i++)
        {
            floor[i] = 1000;
        }
        scanf("%d%d",&a,&b);
        for(i = 1; i <= n; i++)
        {
            scanf("%d",&floor[i]);
        }
        num = Bfs(n,a,b);
        printf("%d\n",num);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值