hdu1698 Just a Hook 线段树 延时更新

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20252    Accepted Submission(s): 10145


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.




Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:   1542  1255  1828  1540  3397 


线段树的区间修改,并且节点非常多,必须使用延时更新,只有下次访问或者需要更新的时候才向下更新,这样说很抽象,下面描述一下详细的过程。

1.在节点上,需要给每个节点设置一个延时标志flag,如果flag=0,说明这个节点不需要向下更新,否则需要向下更新

2.新增PushDown(Int rt,int len)函数,rt表示根节点,len表示这个节点所表示的区间长度,向下更新的时候,需要更新左子树和右子树。

3.在更新的时候,必须先向下更新,也就是完成未完成的更新,然后再完成本次更新内容,最后再回溯向上更新。

#include <iostream>
#include <cmath>
#include <stdio.h>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <iomanip>
#include <algorithm>
#include <memory.h>
#define MAX 400000
using namespace std;

struct Tree
{
    int sum;//该节点所表示区间的总价值
    int flag;//延时标识
};
Tree tree[MAX];


void PushUp(int rt)//向上更新
{
    tree[rt].sum=tree[rt<<1].sum+tree[rt<<1|1].sum;
}

void PushDown(int rt,int len)//向下更新
{
    if(tree[rt].flag!=0)//如果更新标识不为0
    {
        tree[rt<<1].flag=tree[rt<<1|1].flag=tree[rt].flag;//更新左右子树的延时标志
        tree[rt<<1].sum=(len-(len>>1))*tree[rt].flag;//更新左子树的值,注意如果区间长度为奇数,左区间比右区间多1
        tree[rt<<1|1].sum=(len>>1)*tree[rt].flag;//更新右子树的值
        tree[rt].flag=0;
    }
}

void UpDate(int L,int R,int date,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        tree[rt].flag=date;
        tree[rt].sum=(r-l+1)*date;
        return;
    }
    PushDown(rt,r-l+1);//首先完成上次未完成的更新
    int m=(l+r)>>1;
    if(L<=m)
        UpDate(L,R,date,l,m,rt<<1);
    if(R>m)
        UpDate(L,R,date,m+1,r,rt<<1|1);
    PushUp(rt);
}

void Build(int l,int r,int rt)
{
    tree[rt].flag=0;
    if(l==r)
    {
        tree[rt].sum=1;
        return;
    }
    int m=(l+r)>>1;
    Build(l,m,rt<<1);
    Build(m+1,r,rt<<1|1);
    PushUp(rt);
}


int main()
{
    int n,q,t,cas,i;
    int a,b,c;
    scanf("%d",&t);
    for(cas=1;cas<=t;cas++)
    {
        scanf("%d%d",&n,&q);
        Build(1,n,1);
        while(q--)
        {
            scanf("%d%d%d",&a,&b,&c);
            UpDate(a,b,c,1,n,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",cas,tree[1].sum);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值