【白书之路】10082 - WERTYU string使用

10082 WERTYU 

Acommontypingerroristoplacethehandson thekeyboardonerowtotherightofthecorrect position. So ‘Q’ is typed as ‘W’ and ‘J’ is typed as ‘K’ and so on. You are to decode a message typed in this manner. 

Input

Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input. 

Output

You are to replace each letter or punction symbol by the one immediately to its left on the ‘QWERTY’ keyboard shown above. Spaces in the input should be echoed in the output. 

Sample Input

O S, GOMR YPFSU/

Sample Output 

I AM FINE TODAY.


有关字符串的题目,这种题目可以在时间复杂度允许的情况下使用库函数或者stl,这里我是用了string,有一点需要注意:字符串中的反斜杠,这很可能成为错误点。还有尽量不要使用gets,这个函数在比较新的版本中已经被取消了,因为没有对缓冲区溢出进行处理,可以使用fgets(),三个参数,第一个是缓冲区指针,第二个读取的字符数量,第三个是文件流指针,我们可以使用标准流stdin来实现从键盘读入。string的find函数返回所找字符(串)在目标串的起始位置,如果没找到则返回string::npos,使用size_t来接收返回值。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
string dic="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
char str[1000];
int main()
{
    int i;
    size_t pos;
    while(fgets(str,1000,stdin)!=NULL)
    {
       for(i=0;i<strlen(str);i++)
       {
           pos=dic.find(str[i]);
           //printf("pos=%d\n",pos);
           if(pos!=-1)
            str[i]=dic[pos-1];
       }
       printf("%s",str);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值