a+b problem 大数相加

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
这代码虽然通过网上 学习得到的,但也有自己的收获,总体思想是将大整数看做是看做是字符串,与数字分离,按位相加
Presentation Error 就是输出错了,可能是少了回车多了空格什么的。。。
#include <stdio.h>
#include<string.h>
int main()
{
    int n,i,j,k,t,pi,flag,len1,len2;
    char str1[1010],str2[1010];
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
     int s[1200]={0};
     printf("Case %d:\n",i);
    scanf("%s%s",str1,str2);
     len1=strlen(str1);
     len2=strlen(str2);
    printf("%s + %s = ",str1,str2);
     j=len1-1;
     k=len2-1;
     pi=0;
     flag=0;
     while(j>=0&&k>=0)
     {
         if(s[pi]+(str1[j]-'0')+(str2[k]-'0')>=10)
         {
           s[pi]=s[pi]+(str1[j]-'0')+(str2[k]-'0')-10;
           s[pi+1]++;
         }
         else
         {
           s[pi]=s[pi]+(str1[j]-'0')+(str2[k]-'0');
         }
         pi++;
         j--;
         k--;


     }
     if(j>=0)
     {
       for(t=j;t>=0;t--)
       {
           s[pi]=s[pi]+(str1[t]-'0');
           pi++;
       }
     }
     else if(k>=0)
     {
         for(t=k;t>=0;t--)
         {
             s[pi]=s[pi]+str2[t]-'0';
             pi++;
         }
     }
     else if(s[pi]!=0)
     {
         pi++;
     }

     for(t=pi-1;t>=0;t--)
     {
         if(s[t]==0&&flag==0)
                continue;
         else
         {
             flag=1;
           printf("%d",s[t]);
         }

     }
     printf("\n");
     if(i!=n)
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值