概率dp POJ 2151 Check the difficulty of problems

Check the difficulty of problems
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 4028Accepted: 1788

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石


题意:有T个队伍参加比赛,为了让题目难度不那么大,要求每个队伍至少能做出一道题,冠军队伍至少要做出N道题,给出每个队伍能解决各个问题的概率,问符合要求的概率是多少。

思路:正着想可能麻烦一点,我们可以试着反着想,就是先求出不符合要求的概率,然后用1减去这个概率就是所要求的答案。不符合要求的事件有至少有一个队伍做不出任何的题目,这个比较好解决,我们从第一个队伍开始考虑,他只要解不出那么后面的队伍无论是什么情况都是不行的,然后到第二个队伍,第二个队伍解不出,那么后面队伍也是无论什么情况都不满足要求,但是为了防止重复,在考虑第二个队伍时,第一个队伍应该是能回答出题目,因为在考虑第一个队伍时已经考虑了第一个队伍解不出题目,第二个队伍也解不出题目的情况。然后依次类推。我们设Pi 为第i个队伍能回答出题目的概率。那么存在至少一个队伍回答不出题目的概率就是 (1-P1)+P1*(1-P2)+P1*P2*(1-P3)+.......+P1*.....*P(t-1)*(1-Pt)  
然后不符合要求的还有一种情况就是全部人都至少做出一道题目,没有一个队伍能做出达到或超过N个题目。考虑这种情况的时候,我们自然想到如果把每个队伍解出(1~N-1)道题目的概率求出来,总的概率就求出来了。怎么求呢?我们用dp[i][j]表示前i道题目,解出j道题目的概率,那么很容易能想到动态转移方程 dp[i][j] = p[i][j]*dp[i-1][j-1]+(1-p[i][j])*dp[i-1][j];  dp完之后对dp[M][i] (1<=i<N) 求和就是这个队伍解出的题目小于N的概率。
那么如果上面两个问题都解决了,要求的问题自自然然的就解决了。


代码:
#include<iostream>
#include<stdio.h>
#include<cstdio>
#include<algorithm>
#include<math.h>
#include<string.h>
using namespace std;
const int maxn = 1000+10;
const int MOD = 1000000007;
typedef  long long LL;

int M,T,N;
double p[maxn][40];
double dp[40][40];
double cansolve[maxn];

int main()
{
while (scanf("%d%d%d",&M,&T,&N))
{
if (M+T+N==0) return 0;
for (int i = 1 ; i <= T ; ++i)
{
cansolve[i] = 1;
for (int j = 1 ; j <= M ; ++j)
{
scanf("%lf",&p[i][j]);
cansolve[i] *= (1-p[i][j]);
}
cansolve[i] = 1-cansolve[i];
}

double ans = 1 , sum;
for (int i = 1 ; i <= T ; ++i)
{
memset(dp,0,sizeof(dp));
dp[0][0] = 1;
sum = 0;
for (int j = 1 ; j <= M ; ++j)
{
dp[j][0] = (1-p[i][j])*dp[j-1][0];
for (int k = 1 ; k <= j ; ++k)
dp[j][k] = p[i][j]*dp[j-1][k-1]+(1-p[i][j])*dp[j-1][k];
}
for (int j = 1 ; j < N ; ++j)
sum += dp[M][j];
ans *= sum;
}
sum = 0;
for (int i = 1 ; i <= T ; ++i)
{
double tem = 1;
for (int j = 1 ; j < i ; ++j)
tem *= cansolve[j];
tem *= (1-cansolve[i]);
ans += tem;
}
ans = 1-ans;
printf("%.3lf\n",ans);
}
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值