UVA 10237 Bishops

Problem B
Bishops

Input: standard input
Output: standard output
Time Limit: 4 seconds
Memory Limit: 32 MB

 

A bishop is a piece used in the game of chess which is played on a board of square grids. A bishop can only move diagonally from its current position and two bishops attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for bishop B1 form its current position.  The figure also shows that the bishops B1 and B2 are in attacking positions whereas B1 andB3 are not. B2 and B3 are also in non-attacking positions.

 

 

Now, given two numbers n and k, your job is to determine the number of ways one can put k bishops on an n × n chessboard so that no two of them are in attacking positions.

 

Input

 The input file may contain multiple test cases. Each test case occupies a single line in the input file and contains two integers n (1 ≤ n ≤ 30) andk (0 ≤ k ≤ n2).

 

A test case containing two zeros for n and k terminates the input and you won’t need to process this particular input.

 

Output

For each test case in the input print a line containing the total number of ways one can put the given number of bishops on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1015.

 

Sample Input
8 6
4 4
20 40
30 5
0 0

 

Sample Output
5599888
260
0
3127859642656

(World Finals Warm-up Contest, Problem setter: Rezaul Alam Chowdhury)

 

 

"I think Garry Kasparov will like this problem very much!!!"
思路:其实关键是放棋的顺序,显然一条斜线只能放一个,但是仅仅是这样是不能“打包”统计的。因为每条斜线上放什么位置是会互相影响的。 但是注意到短的斜线会影响长的斜线。 所以放棋的顺序可以是先放短的斜线,再考虑长的,这样我们直接dp就行了。第奇数条斜线会相互影响,第偶数条会相互影响。 我们用dp[i][j]表示已经选择了i条斜线放棋,并且“奇”斜线选择了j条,那么我们就能有dp[i+1][j+1] += dp[i][j] * (w - j) 和dp[i+1][j] += dp[i][j] * (w - (i - j)) 了。 


代码:

#include <iostream>
#include <vector>
#include <algorithm>
#include <string.h>
#include <cstring>
#include <stdio.h>
#include <cmath>
#include <cassert>
#include <math.h>
#define rep(i,a,b) for(int i=(a);i<(b);++i)
#define rrep(i,b,a) for(int i = (b); i >= (a); --i)
#define clr(a,x) memset(a,(x),sizeof(a))
#define LL long long
#define eps 1e-10
using namespace std;
const int maxn = 60 + 5;
int N,K;
LL dp[maxn][maxn];

int main()
{
    //Getinput();return 0;
    #ifdef ACM
        freopen("in.txt", "r", stdin);
       // freopen("out.txt","w",stdout);
    #endif // ACM
    while (scanf("%d%d",&N,&K)==2) {
        if (N+K==0) break;

        if (K > N * 2 - 1) puts("0");
        else {
            clr(dp,0);
            dp[0][0]= 1;
            vector<int> v;
            rep(i,1,N) {
                v.push_back(i);
                v.push_back(i);
            }
            v.push_back(N);

            rep(i,0,v.size()) {
                int x = v[i];
                rrep(j,i,0) rep(k,0,j+1) if (dp[j][k]) {
                    if (x & 1) dp[j+1][k+1] += dp[j][k] * (x - k);
                    else dp[j+1][k] += dp[j][k] * (x - (j - k));
                }
            }
            LL ans = 0;
            rep(i,0,N+1) ans += dp[K][i];
            printf("%lld\n",ans);
        }
    }
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值