PAT1008. Elevator (20)

题目如下:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41
很简单的一道给出电梯停留的层数,上升、下降和停留所需要的时间,计算总时间的题目。我自己一开始题目没看清楚,以为题目用例给出的4个数字都是停留的层数,导致对题意理解了好久,后来弄懂题目后就知道是很简单的题目了。代码如下:

#include <iostream>
using namespace std;
int main() 
{
	int N, now = 0, sum = 0;
	int floor;
	cin >> N;
	for (int i = 0;i < N;i++)
	{
		cin >> floor;
		if (floor > now)
			sum += (floor - now) * 6;
		else if (floor < now)
			sum += (now - floor) * 4;
		now = floor;
		sum += 5;
	}

	cout << sum;
	return 0;
}
所有用例都通过了,没有什么难度。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值