PAT1015. Reversible Primes (20)

题目如下:

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

题意就是给出一个数据以及他的进制,让你判断他以及他的每位进行倒置后形成的新数字是否都是素数。那么就先写一个判断是否是素数的函数,这里要注意对1进行特判,我一开始忘了考虑1不是素数,导致用例1错误。然后再写倒置的函数,因为读进来的都是十进制,所以在倒置的函数中先十进制转换为相应的进制,将每位按顺序加入字符串,这个时候字符串里已经是倒置了,然后从末尾开始处理,再转换成新的十进制即可,再对原数和转换后的数都判断下是否是素数即可。代码如下:

#include <iostream>
#include <string>
#include <cmath>
using namespace std;
int reverseNum(int number,int radix)
{
	string s;
	int newNum = 0;
	int digit;
	do {
		digit = number % radix;
		s.push_back(digit);
		number /= radix;
	} while (number != 0);
	for (int i = s.size() - 1,j = 0;i >= 0;i--,j++)
	{
		newNum += s[i] * pow(radix,j);
	}
	return newNum;
}
bool isPrime(int number)
{
	if (number == 1)
		return false;
	for (int i = 2;i * i <= number;i++)
	{
		if (number % i == 0)
			return false;
	}
	return true;
}
int main()
{
	int N, D,newNum;
	cin >> N;
	while (N > 0)
	{
		cin >> D;
		newNum = reverseNum(N, D);
		if (isPrime(N) && isPrime(newNum))
			cout << "Yes" << endl;
		else
			cout << "No" << endl;

		cin >> N;
	}
	return 0;
}

通过所有用例。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值