Eight

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 

 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x


where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 

 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->


The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement. 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases. 

Sample Input

2  3  4  1  5  x  7  6  8

Sample Output

ullddrurdllurdruldr
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<iostream>
#include<queue>
using namespace std;

int fac[]= {1,1,2,6,24,120,720,5040,40320,362880};
int dir[4][2]= {{-1,0},{1,0},{0,-1},{0,1}};

struct node
{
    int s[10];
    int x;
    int vis;
    string sr;
};

int vis[500010],ss[9];
string str[500010];
char index[5]="durl";

int Hash(int a[])
{
    int sum=0;
    for(int i=1; i<=8; i++)
    {
        int num=0;
        for(int j=0; j<i; j++)
            if(a[j]>a[i])
                num++;
        sum+=num*fac[i];
    }
    return sum;
}

void bfs()
{
    memset(vis,0,sizeof(vis));
    queue<node>Q;
    node now,next;
    for(int i=0; i<=8; i++)
        now.s[i]=i+1;
    now.x=8;
    now.vis=Hash(now.s);
    now.sr="";
    str[now.vis]="";
    Q.push(now);
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        int x=now.x/3;
        int y=now.x%3;
        for(int i=0; i<4; i++)
        {
            int xx=x+dir[i][0];
            int yy=y+dir[i][1];
            if(xx>=0&&xx<=2&yy>=0&&yy<=2)
            {
                next=now;
                next.x=xx*3+yy;
                next.s[now.x]=next.s[next.x];
                next.s[next.x]=9;
                next.vis=Hash(next.s);
                if(!vis[next.vis])
                {
                    vis[next.vis]=1;
                    next.sr=index[i]+next.sr;
                    str[next.vis]=next.sr;
                    Q.push(next);
                }
            }
        }
    }
}
int main()
{
    char s[1100];
    bfs();//首先从最终状态向各个方向搜索
    while(gets(s))
    {
        int k=0;
        for(int i=0; i<strlen(s); i++)
        {
            if(s[i]>='0'&&s[i]<='9')
                ss[k++]=s[i]-'0';
            else if(s[i]=='x')
                ss[k++]=9;
        }
        if(vis[Hash(ss)])//判断该状态是否出现
            cout<<str[Hash(ss)]<<endl;
        else
            cout<<"unsolvable"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值