poj3463 Sightseeing(最短路,次短路计数)

Description

Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

M lines, each with three integers A, B and L, separated by single spaces, with 1 ≤ A, B ≤ N, A ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.

The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

One line with two integers S and F, separated by a single space, with 1 ≤ S, F ≤ N and S ≠ F: the starting city and the final city of the route.

There will be at least one route from S to F.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 109 = 1,000,000,000.

Sample Input
2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

Sample Output
3
2

Hint

The first test case above corresponds to the picture in the problem description.

分析:
博主有专门翻译过这道题

本题是求最短路和次短路的条数
我们就需要开两个数组,dis[N][2],cnt[N][2]
dis[i][0]表示到达i节点的最短路的长度
dis[i][1]表示到达i节点的次短路长度
cnt[i][0]表示到达i节点的最短路条数
cnt[i][1]表示到达i节点的次短路条数

有四种转移状态,很方
看一下程序吧
这里写图片描述

我在这里用的是dijkstra
注意这里我们循环了2*n-1次
为什么我们要循环2*n-1次?
显然这道题中我们每一条边都需要考虑,
这不是在求最短的一条,说白了是让你求出所有的可能组合,
姑且就理解为其中n-1次是用来求最短路的,还有n次是次短路的

tip

都是单向边!!!

这里写代码片
#include<cstdio>
#include<cstring>
#include<iostream>
#define ll long long

using namespace std;

const int N=1002;
const ll INF=1e15;
struct node{
    int x,y,nxt;
    ll v;
};
node way[N*10];
ll dis[N][2];
int n,m,tot,st[N],s,t,tt=0,cnt[N][2];
bool p[N][2];

void add(int u,int w,int z)
{
    tot++;
    way[tot].x=u;way[tot].y=w;way[tot].v=(ll)z;way[tot].nxt=st[u];st[u]=tot;
}

void dij(int s,int t)
{
    int i,j,k,flag;
    memset(p,1,sizeof(p));
    memset(cnt,0,sizeof(cnt));
    for (int i=1;i<=n;i++) 
        dis[i][1]=INF,dis[i][0]=INF;
    dis[s][0]=0;   //最短路
    cnt[s][0]=1;
    for (i=1;i<=2*n-1;i++)
    {
        ll mn=INF; k=0;
        for (j=1;j<=n;j++)   //在所有的路径中找到最短的一条 
            if (p[j][0]&&dis[j][0]<mn)
            {
                mn=dis[j][0];
                k=j;
                flag=0;
            }
            else if (p[j][1]&&dis[j][1]<mn)
            {
                mn=dis[j][1];
                k=j;
                flag=1;
            }
        if (mn==INF) break;

        p[k][flag]=0;

        for (j=st[k];j;j=way[j].nxt)   //k就是转移点的编号 
        {
            int y=way[j].y; int w=way[j].v;
            if (dis[y][0]>mn+w)
            {
                dis[y][1]=dis[y][0]; cnt[y][1]=cnt[y][0];
                dis[y][0]=mn+w; cnt[y][0]=cnt[k][flag];
                //该状态下的最短路条数就是转移点的状态cnt 
            } 
            else if (dis[y][0]==mn+w)  //等于最短路
            {
                cnt[y][0]+=cnt[k][flag];
            }
            else if (dis[y][1]>mn+w)
            {
                dis[y][1]=mn+w;
                cnt[y][1]=cnt[k][flag];
            }
            else if (dis[y][1]==mn+w)  //等于最短路
            {
                cnt[y][1]+=cnt[k][flag];
            }
        }
    } 
    if (dis[t][1]==dis[t][0]+1)
        printf("%d\n",cnt[t][0]+cnt[t][1]);
    else printf("%d\n",cnt[t][0]);
}

int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        tt=0;
        scanf("%d%d",&n,&m);
        memset(st,0,sizeof(st));
        tot=0;
        for (int i=1;i<=m;i++)
        {
            int u,w,z;
            scanf("%d%d%d",&u,&w,&z);
            add(u,w,z);
        }
        scanf("%d%d",&s,&t);
        dij(s,t);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值