【计算几何】Fishnet


Fishnet
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1296 Accepted: 820

Description

A fisherman named Etadokah awoke in a very small island. He could see calm, beautiful and blue sea around the island. The previous night he had encountered a terrible storm and had reached this uninhabited island. Some wrecks of his ship were spread around him. He found a square wood-frame and a long thread among the wrecks. He had to survive in this island until someone came and saved him.

In order to catch fish, he began to make a kind of fishnet by cutting the long thread into short threads and fixing them at pegs on the square wood-frame. He wanted to know the sizes of the meshes of the fishnet to see whether he could catch small fish as well as large ones.

The wood frame is perfectly square with four thin edges on meter long: a bottom edge, a top edge, a left edge, and a right edge. There are n pegs on each edge, and thus there are 4n pegs in total. The positions of pegs are represented by their (x,y)-coordinates. Those of an example case with n=2 are depicted in figures below. The position of the ith peg on the bottom edge is represented by (ai,0). That on the top edge, on the left edge and on the right edge are represented by (bi,1), (0,ci) and (1,di), respectively. The long thread is cut into 2n threads with appropriate lengths. The threads are strained between (ai,0) and (bi,1),and between (0,ci) and (1,di) (i=1,...,n).

You should write a program that reports the size of the largest mesh among the (n+1)2 meshes of the fishnet made by fixing the threads at the pegs. You may assume that the thread he found is long enough to make the fishnet and the wood-frame is thin enough for neglecting its thickness.

Input

The input consists of multiple sub-problems followed by a line containing a zero that indicates the end of input. Each sub-problem is given in the following format.
n
a1 a2 ... an
b1 b2 ... bn
c1 c2 ... cn
d1 d2 ... dn
you may assume 0 < n <= 30, 0 < ai,bi,ci,di < 1

Output

For each sub-problem, the size of the largest mesh should be printed followed by a new line. Each value should be represented by 6 digits after the decimal point, and it may not have an error greater than 0.000001.

Sample Input

2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0

Sample Output

0.215657
0.111112
0.078923
0.279223
0.348958

Source

Japan 2001


O(n^2)的枚举。
一个矩形区域必定由相邻的两根横线和相邻的两根竖线决定。枚举就行了,注意要加四个边框。

要注意,以后算交点,算面积,在叉乘的时候一定要求绝对值,fabs,因为这个错了很多次了。

#include <cmath>
#include <algorithm>
#include <cstdio>
using std::sort;

double a[40];
double b[40];
double c[40];
double d[40];

struct Point
{
	double x;
	double y;
	Point(double xx,double yy):x(xx),y(yy){}
	Point(){}
};

double MAX(double a,double b)
{
	return a>b?a:b;	
}

double Calc2(Point& p1,Point& p2,Point& p3)
{
	double x1 = p3.x-p1.x;
	double x2 = p2.x-p1.x;
	double y1 = p3.y-p1.y;
	double y2 = p2.y-p1.y;
	return fabs(x1*y2-x2*y1)/2.0;
}

double Calc(Point& p1,Point& p2,Point& p3,Point& p4)
{
	return Calc2(p1,p2,p4) + Calc2(p1,p3,p4);	
}

double cross_product(Point p1,Point p2)
{
	return p1.x*p2.y-p1.y*p2.x;	
}

void cross(long i,long j,Point& p2)
{
	double cp1 = cross_product(Point(b[i]-a[i],1),Point(1,d[j]-c[j]));
	double cp2 = cross_product(Point(b[i],1-c[j]),Point(a[i],-c[j]));
	double cps = fabs(cp2/cp1);	
	p2.x = cps;
	p2.y = (d[j]-c[j])*cps+c[j];
}

int main()
{
	freopen("fishnet.in","r",stdin);
	freopen("fishnet.out","w",stdout);
	
	while (1)
	{
		long n;scanf("%ld",&n);
		if (!n) break;
		for (long i=2;i<n+2;i++)
			scanf("%lf",a+i);
		for (long i=2;i<n+2;i++)
			scanf("%lf",b+i);
		for (long i=2;i<n+2;i++)
			scanf("%lf",c+i);
		for (long i=2;i<n+2;i++)
			scanf("%lf",d+i);
		a[1] = 0;b[1] = 0;
		c[1] = 0;d[1] = 0;
		n += 2;
		a[n] = 1;b[n] = 1;
		c[n] = 1;d[n] = 1;
		sort(a+1,a+1+n);
		sort(b+1,b+1+n);
		sort(c+1,c+1+n);
		sort(d+1,d+1+n);
		double ans = 0;
		for (long i=1;i<n;i++)
		{
			for (long j=1;j<n;j++)
			{
				Point p1,p2,p3,p4;
				cross(i,j,p1);
				cross(i,j+1,p2);
				cross(i+1,j,p3);
				cross(i+1,j+1,p4);
				
				ans = MAX(ans,Calc(p1,p2,p3,p4));
			}	
		}
		printf("%.6f\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值