扩展欧几里得-逆元 浙江2012年省赛J题 Modular Inverse

扩展欧几里得-逆元 浙江2012年省赛J题 Modular Inverse

Time Limit: 2000MS   Memory Limit: 65535KB   64bit IO Format:

 Status

Description

The modular modular multiplicative inverse of an integer  a modulo  m is an integer  x such that  a-1x (mod m). This is equivalent to  ax≡1 (mod m)

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases. 

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8

Hint

Source

浙江2012年省赛J题

(a*x)%m=1 扩展欧几里得求ax+my=1  x>0的最小整数解 

#include<iostream>
#include<cstdio>
using namespace std;
#define ll __int64

ll x, y;
ll exgcd(ll a, ll b){
    if(b == 0){
        x = 1;
        y = 0;
        return a;
    }
    ll d = exgcd(b, a%b);
    ll t = x;
    x = y;
    y = t-a/b*y;
    return d;
}

int main(){
    ll a, b, T;
    scanf("%I64d",&T);
    while(T--){
        scanf("%I64d%I64d",&a,&b);
        if(b==1){
            printf("1\n");
            continue;
        }
        //cout<<a<<b<<endl;
        //ll g = 0;
        ll g = exgcd(a, b);
        if(g == 1){
            while(x < 0){
                x += b;
                y -= a;
            }
            printf("%I64d\n",x);
        }
        else
            printf("Not Exist\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值