poj-2955 括号匹配--简单区间dp

http://poj.org/problem?id=2955

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5970 Accepted: 3183

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1,i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

基础区间dp

题意:给你一个字符串由'('、')'、'['、']'组成,问此串的括号最大匹配是多少

首先定义dp[i][j]表示第i到第j个括号的最大匹配数,遍历整个串,当ch[i]与ch[j]匹配时,dp[i][j] = dp[i+1][j-1]+2

只需要从小到大枚举所有 i 和 j 中间的括号数目,然后满足匹配就用上面式子dp,然后每次更新dp [ i ] [ j ]为最大值

然后需要更新dp[i][j]的最大值,方法是遍历i到j中的值dp[i][j] = max(dp[i][j], dp[i][s]+dp[s+1][j]);

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
int dp[1100][1100];
int main(){
    int i, j, k;
    string ch;
    while(cin>>ch){
        if(ch=="end")
            break;
        int l = ch.size();
        memset(dp, 0, sizeof(dp));
        for(i=0; i<l; i++){
            for(j=0; j<l; j++){
                dp[i][j] = max()
            }
        }
        for(k=0; k<l; k++){
            for(i=0, j=k; j<l&&i<l; j++, i++){
                if((ch[i]=='('&&ch[j]==')')||(ch[i]=='['&&ch[j]==']'))
                    dp[i][j] = dp[i+1][j-1]+2;
                for(int s=i; s<j; s++)
                    dp[i][j] = max(dp[i][j], dp[i][s]+dp[s+1][j]);
            }
        }
//        for(i=0; i<l; i++){
//            for(j=0; j<l; j++){
//                printf("%d ",dp[i][j]);
//            }
//            printf("\n");
//        }
        cout<<dp[0][l-1]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值