Square

Square

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 2
Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source
University of Waterloo Local Contest 2002.09.21
 
思路:可以简化为01背包,但超时。
代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
int value[25];
int dist[1000005];
int n , m;
void init()
{
    for(int i = 0; i <= m; i ++)
    {
        dist[i] = 0;
    }
}
int main()
{
    int t ;
    scanf("%d",&t);
    while(t --)
    {
        scanf("%d",&n);
        m = 0;
        for(int i = 0; i < n; i ++)
        {
            scanf("%d",&value[i]);
            m += value[i];
        }
        if(m % 4) {
            printf("no\n");
            continue;
        }
        init();
        for(int i = 0; i < n; i ++)
        {
            for(int j = m; j >= value[i]; j --)
            {
                dist[j] = max(dist[j] , dist[j-value[i]]+value[i]);
            }
        }
        m /= 4;
        if(dist[m] == m && dist[2*m] == 2*m && dist[3*m] == 3 *m)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}
正确代码如下:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int vist[30];
int data[30];
int n , m ,len;

int dfs(int temp , int time , int y)
{
    if(time == 3)return 1;
    for(int i = y; i >= 0; i --)
    {
        if(!vist[i])
        {
            vist[i] = 1;
            if(temp+data[i] == len)
            {
                if(dfs(0 , time + 1 , n))return 1;
            }
            else if(temp+data[i] < len)
            {
                if(dfs(temp+data[i] , time , i-1))return 1;//如果在i处末搜到一条边,下次一定是在0到i-1中搜索。否则超时。
            }
            vist[i] = 0;
        }
    }
    return 0;
}
int main()
{
    int t ;
    scanf("%d",&t);
    while(t --)
    {
        m = 0;
        scanf("%d",&n);
        for(int i = 0; i < n; i ++)
        {
            scanf("%d",&data[i]);
            m += data[i];
        }
        sort(data , data+n);
        memset(vist , 0 , sizeof(vist));
        if(m % 4 ==0 &&data[n-1] <= m/4&&n >= 4)
        {
            len = m/4;
            if(dfs(0 , 0 , n -1))printf("yes\n");
            else
                printf("no\n");
        }
        else
            printf("no\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值