HDU 1796 How many integers can you find(组合数学-容斥原理)

How many integers can you find

Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
  
  
12 2 2 3
 

Sample Output
  
  
7
 

Author
wangye
 

Source
 

Recommend
wangye


题目大意:
输入N,和M个数,求出1~N-1中,有几个数能被M个数任意一个整除。

解题思路:
利用容斥原理。被任意一个整除的个数 = 同时被一个整除 - 同时被两个整除 + 同时被三个整除 - ...
A∪B∪C = A+B+C - A∩B - B∩C - C∩A +A∩B∩C
区间[1,N]中能同时被x1, x2, ..., xm整除的数的个数 = N / lcm(x1, x2, ..., xm)

可以用位运算,简化枚举状态的过程。

参考代码:
#include <iostream>
#include <vector>
using namespace std;

vector<int> a;
int n, m;
long long ans;

long long gcd(long long x, long long y) {
    return y > 0 ? gcd(y, x % y) : x;
}

long long lcm(long long x, long long y) {
    return x * y / gcd(x, y);
}

void init() {
    a.clear();
    ans = 0;
}

void input() {
    for (int i = 0; i < m; i++) {
        int x;
        cin >> x;
        if (x > 0) {
            a.push_back(x);
        }
    }
    m = a.size();
}

void work() {
    for (int i = 1; i < (1 << m); i++) {
        long long x = 1;
        int cnt = 0;
        for (int j = 0; j < m; j++) {
            if (i & (1 << j)) {
                cnt++;
                x = lcm(x, a[j]);
            }
        }
        if (cnt & 1) {
            ans += (n - 1) / x;
        } else {
            ans -= (n - 1) / x;
        }
    }
}

void output() {
    cout << ans << endl;
}

int main() {
    ios::sync_with_stdio(false);
    while (cin >> n >> m) {
        init();
        input();
        work();
        output();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值