UVa11968 - In The Airport

R   — In The Airport

Time Limit: 1 sec
Memory Limit: 32 MB

It’s a Wednesday night and Bob is sitting at the airport and waiting for an airplain to Lithuania. The challenge he is facing is to come up with an easy task for the qualification contest on Saturday in KTU. Unfortunately, he doesn’t have any more ideas because it’s already late and he is too exhausted.

To freshen up, he thinks that he should get a drink and a piece of cake. Waitress gives Bob a menu to choose from. As he was too busy thinking about how tired he is, he simply decided to go for a drink and piece of cake which are the closest to the average of all items on the menu. If he needs to choose, he always goes for the cheaper item. Unfortunately waitress is not very good at math, and obviously she needs your help!

INPUT

You are given (T ≤ 100) tests on the first line. Each test starts with a line containing the integers NM,K, where (2 ≤ N ≤ 1000) is the number of items on the menu, (1 ≤ M ≤ N) is the number of cakes on the menu and (1 ≤ K ≤ N) is the number of drinks on the menu. Next line contains exactly N positive integers, where the first M integers specify the prices for cakes, next K integers (0 ≤ Pi ≤ 109) specify drink prices, and the following prices are for all other items on the menu.

OUTPUT

For each test case you have to output a line "Case #T: A B". Where T is the test case number, A specifies the closest price of the cake to the average of all items, and B is the closest price of the drink to the average of all items. Refer sample output for details.

SAMPLE INPUT

2
4 1 1
1 2 3 4
5 1 2
500000000 5 6 1000000000 1000000000

SAMPLE OUTPUT

Case #1: 1 2
Case #2: 500000000 6

import java.io.IOException;
import java.io.FileInputStream;
import java.io.InputStreamReader;
import java.io.BufferedReader;
import java.io.PrintWriter;
import java.io.OutputStreamWriter;
import java.io.StreamTokenizer;

public class Main
{
	public static boolean DEBUG = false;
	public BufferedReader cin;
	public PrintWriter cout;
	public StreamTokenizer tokenizer;
	public int n, m, k;
	public long total;
	public long[] mArr, nArr, kArr;
	
	public void init()
	{
		try {
			if (DEBUG) {
				cin = new BufferedReader(new InputStreamReader(
						new FileInputStream("d:\\OJ\\uva_in.txt")));
			} else {
				cin = new BufferedReader(new InputStreamReader(System.in));
			}
		} catch (IOException e) {
			e.printStackTrace();
		}
		
		cout = new PrintWriter(new OutputStreamWriter(System.out));
		tokenizer = new StreamTokenizer(cin);
	}
	
	public String next()
	{
		try {
			tokenizer.nextToken();
			if (tokenizer.ttype == StreamTokenizer.TT_EOF)
				return null;
			else if (tokenizer.ttype == StreamTokenizer.TT_WORD)
				return tokenizer.sval;
			else if (tokenizer.ttype == StreamTokenizer.TT_NUMBER) 
				return String.valueOf((int)tokenizer.nval);
		} catch (IOException e) {
			e.printStackTrace();
		}
		
		return null;
		
	}
	
	public void input()
	{
		try {
			n = Integer.parseInt(next());
			m = Integer.parseInt(next());
			k = Integer.parseInt(next());
			
			total = 0;
			mArr = new long[m];
			kArr = new long[k];
			nArr = new long[n - m - k];
			
			for (int i = 0; i < m; i++) {
				mArr[i] = Long.parseLong(next());
				total += mArr[i];
			}
			
			for (int i = 0; i < k; i++) {
				kArr[i] = Long.parseLong(next());
				total += kArr[i];
			}
			
			int tmpn = n - m - k;
			for (int i = 0; i < tmpn; i++) {
				nArr[i] = Long.parseLong(next());
				total += nArr[i];
			}
			
		} catch (Exception e) {
			e.printStackTrace();
		}
	}
	
	
	public void solve(int t)
	{
		cout.printf("Case #%d: ", t);
		
		int ans1 = 0, ans2 = 0;
		
		for (int i = 0; i < m; i++) {
			long tmp1 = n * mArr[i] - total;
			long tmp2 = n * mArr[ans1] - total;
			
			if (Math.abs(tmp1) < Math.abs(tmp2)) ans1 = i;
			else if (Math.abs(tmp1) == Math.abs(tmp2) && mArr[i] < mArr[ans1]) ans1 = i;
		}
		
		for (int i = 0; i < k; i++) {
			long tmp1 = n * kArr[i] - total;
			long tmp2 = n * kArr[ans2] - total;
			
			if (Math.abs(tmp1) < Math.abs(tmp2)) ans2 = i;
			else if (Math.abs(tmp1) == Math.abs(tmp2) && kArr[i] < kArr[ans2]) ans2 = i;
		}
		
		cout.printf("%d %d", mArr[ans1], kArr[ans2]);
		cout.println();
		cout.flush();
	}
	
	public static void main(String[] args)
	{
		try {
			Main solver = new Main();
			solver.init();
			
			int t = Integer.parseInt(solver.next());
			for (int i = 1; i <= t; i++) {
				solver.input();
				solver.solve(i);
			}
		} catch (Exception e) {
			e.printStackTrace();
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值