UVa11254 - Consecutive Integers(判断一个数是不是2的幂)

Problem B - Consecutive Integers


Any positive integer can be written as the sum of several consecutive integers. For example,
15=1 + ... + 5
 =4 + ... + 6
 =7 + ... + 8
 =15 + ... + 15

Given a positive integer n, what are the consecutive positive integers with sum being n? If there are multiple solutions, which one consists of more numbers?

Input
Input consists of multiple problem instances. Each instance consists of a single positive integer n, where n 10 9. The input data is terminated by a line containing -1. There will be at most 1000 test cases.

Output
For each input integer n, print out the desired solution with the format:
N = A + ... + B
in a single line.
(Read sample output for a clearer representation of the exact formatting.)

Sample input
8
15
35
-1

Sample output
8 = 8 + ... + 8
15 = 1 + ... + 5
35 = 2 + ... + 8

涉及到判断一个数是不是2的幂

import java.io.FileInputStream;
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.PrintWriter;
import java.io.OutputStreamWriter;
import java.io.StreamTokenizer;

public class Main 
{
	private static final boolean DEBUG = false;
	private BufferedReader cin;
	private PrintWriter cout;
	private StreamTokenizer tokenizer;
	private int n;
	
	public void init() 
	{
		try {
			if (DEBUG) {
				cin = new BufferedReader(new InputStreamReader(
						new FileInputStream("d:\\OJ\\uva_in.txt")));
			} else {
				cin = new BufferedReader(new InputStreamReader(System.in));
			}

			tokenizer = new StreamTokenizer(cin);
			cout = new PrintWriter(new OutputStreamWriter(System.out));
		} catch (Exception e) {
			e.printStackTrace();
		}
	}

	private String next() 
	{
		try {
			tokenizer.nextToken();
			if (tokenizer.ttype == StreamTokenizer.TT_EOF)
				return null;
			else if (tokenizer.ttype == StreamTokenizer.TT_NUMBER) {
				return String.valueOf((int) tokenizer.nval);
			} else
				return tokenizer.sval;
		} catch (Exception e) {
			e.printStackTrace();
			return null;
		}
	}

	public boolean input() 
	{
		n = Integer.parseInt(next());
		
		if (n == -1) return false;
		
		return true;
	}

	public void solve() 
	{
		if ((n & (n - 1)) == 0) {
			cout.println(n + " = " + n + " + ... + " + n);
			cout.flush();
			return;
		}
		
		int t = n * 2;
		int a = 0, b = 0;
		
		int m = (int)Math.sqrt(t);
		while (true) {
			if (t % m != 0) {
				m--;
				continue;
			}
			
			int x = t / m;
			if (((x + m) & 1) == 0) {
				m--;
				continue;
			} else {
				a = (x - m + 1) / 2;
				b = x - a;
				break;
			}
		}
		
		cout.println(n + " = " + a + " + ... + " + b);
		cout.flush();
	}

	public static void main(String[] args) 
	{
		Main solver = new Main();
		solver.init();

		while (solver.input()) {
			solver.solve();
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值