UVa10312 - Expression Bracketing(Catalan和super catalan)

Inthis problem you will have to find in how many ways n letters can be bracketed so that the bracketing is non-binarybracketing. For example 4 lettershave 11 possible bracketing:

 

xxxx, (xx)xx, x(xx)x, xx(xx),(xxx)x, x(xxx), ((xx)x)x, (x(xx))x, (xx)(xx), x((xx)x), x(x(xx)). Of these the first sixbracketing are not binary. Given the number of letters you will have to findthe total number of non-binary bracketing.

 

Input

Theinput file contains several lines of input. Each line contains a single integern (0<n<=26). Input isterminated by end of file.

 

Output

For each line of input produce one line of outputwhich denotes the number of non binary bracketing with n letters.

 

Sample Input

3

4

5

10

 

Sample Output

1

6

31

98187


题意:给出n个括号,求出非二叉结构的数目

思路:超卡特兰数和卡特兰数

#include <cstdio>

using namespace std;

const int MAXN = 30;

typedef long long LL;

LL C[MAXN], S[MAXN];

void init()
{
    C[0] = 1;
    
    for (int i = 1; i < MAXN; i++) {
        C[i] = 0;
        for (int j = 0; j < i; j++) {
            C[i] += C[j] * C[i - 1 - j];
        }
    }
    
    S[0] = S[1] = S[2] = 1;
    for (int i = 3; i < MAXN; i++) {
        S[i] = (3 * (2 * i - 3) * S[i - 1] - (i - 3) * S[i - 2]) / i;
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("/cygdrive/d/OJ/uva_in.txt", "r", stdin);
#endif
    
    int n;
    init();
    while (scanf("%d", &n) != EOF) {
        printf("%lld\n", S[n] - C[n - 1]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值