POJ 2247 Humble Numbers

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence.

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

题目大意:

如果一个数的质因子只有2、3、5或7,那么成这个数为humble number,前20个humble numbers为1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27

输入一个数n,输出第n个humble number

思路:

如果一个数是humble number,那么这个数的2、3、5和7倍一定也是humble number

我们定义一个数组f[i]表示第i个humble number,那么它一定等于前i个humble numbers中某一个humble number的2、3、5或7倍

首先我想到的是暴力枚举,时间复杂度为O(knlogn)找前i个humble numbers中所有2、3、5、7倍且大于第i-1个humble number的最小值

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <string>
#include <unordered_map>

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> PII;

const int N = 6000, mod = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const double PI = acos(-1.0);

int n;
ll f[N];
int a[4] = {2, 3, 5, 7};
int main()
{
    memset(f, inf, sizeof f);
    f[1] = 1;
    for (int i = 2; i <= 5842; i ++ )
    {
        for (int j = 1; j <= i; j ++ )
        {
            for (int k = 0; k < 4; k ++ )
            {
                if (a[k] * f[j] > f[i - 1])
                {
                    f[i] = min(f[i],a[k] * f[j]);
                }
            }
        }
    }
    while (~scanf("%d", &n))
    {
        if (n == 0)  break;
        if (n % 10 == 1 && n % 100 != 11) printf("The %dst humble number is ", n);
        else if (n % 10 == 2 && n % 100 != 12) printf("The %dnd humble number is ", n);
        else if (n % 10 == 3 && n % 100 != 13) printf("The %drd humble number is ", n);
        else printf("The %dth humble number is ", n);
        printf("%d.\n", f[n]);
    }
    return 0;
}

当然这是数据范围小的情况下可以暴力,然后我看别人博客里的题解才发现还有时间复杂度O(k*n)的做法

我们知道若一个数是humble数,那么他的2、3、5、7倍仍然是humble数。

我们定义4个对应2、3、5、7倍索引,初始都指向第一个humble数,然后比较这个索引对应的humble数乘以对应的倍数,取最小值,即为第i个humble数,f[i]对应哪个索引的倍数,对应索引就++, 因为要保证最小值大于第i-1个humble数。

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <string>

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> PII;

const int N = 6000, mod = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const double PI = acos(-1.0);

int n;
ll f[N];
int idx1, idx2, idx3, idx4;
int main()
{
    f[1] = idx1 = idx2 = idx3 = idx4 = 1;
    for (int i = 2; i <= 5842; i ++ )
    {
        f[i] = min(min(min(f[idx1] * 2, f[idx2] * 3), f[idx3] * 5), f[idx4] * 7);
        if (f[i] == f[idx1] * 2) idx1 ++;
        if (f[i] == f[idx2] * 3) idx2 ++;
        if (f[i] == f[idx3] * 5) idx3 ++;
        if (f[i] == f[idx4] * 7) idx4 ++;
    }

    while (~scanf("%d", &n))
    {
        if (n == 0) break;
        if (n % 10 == 1 && n % 100 != 11) printf("The %dst humble number is ", n);
        else if (n % 10 == 2 && n % 100 != 12) printf("The %dnd humble number is ", n);
        else if (n % 10 == 3 && n % 100 != 13) printf("The %drd humble number is ", n);
        else printf("The %dth humble number is ", n);
        printf("%lld.\n", f[n]);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值