hdu1570 A C(组合排列公式使用)


Problem Description
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.




Now I will give you n and m , and your task is to calculate the answer .
 

Input
In the first line , there is a integer T indicates the number of test cases.
Then T cases follows in the T lines.
Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)
 

Output
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).
And print the answer in a single line.
 

Sample Input
  
  
2 A 10 10 C 4 2
 

Sample Output
  
  
3628800 6
 思路:首先计算1到10之间的阶乘表,计算时直接查表即可
代码如下
import java.io.FileInputStream;
import java.io.OutputStreamWriter;
import java.io.InputStreamReader;
import java.io.PrintWriter;
import java.util.Scanner;

public class Main implements Runnable
{  
    private static final boolean DEBUG = false;
    private Scanner cin;
    private PrintWriter cout;
    private int n, m;
    private static final int N = 11;
    private static final int[] fact = new int[N];
    private String str;
    
    private void init()
    {
        try {
            if (DEBUG) {
                cin = new Scanner(new InputStreamReader(new FileInputStream("f:\\OJ\\uva_in.txt")));
            } else {
                cin = new Scanner(new InputStreamReader(System.in));
            }
            
            cout = new PrintWriter(new OutputStreamWriter(System.out));
            
            fact[0] = 1;
            for (int i = 1; i < N; i++) {
                fact[i] = i * fact[i - 1];
            }
        } catch (Exception e) {
            e.printStackTrace();
        }  
    }
    
    private boolean input()
    {
        str = cin.next();
        n = cin.nextInt();
        m = cin.nextInt();
        
        return true;
    }
    
    private void solve()
    {
        int ans = 0;
        
        if (str.compareTo("A") == 0) {
            ans = fact[n] / fact[n - m];
        } else {
            ans = fact[n] / (fact[n - m] * fact[m]);
        }
        
        cout.println(ans);
        cout.flush();
    }
    
    @Override
    public void run()
    {
        init();
        
        int t = cin.nextInt();
        while (t-- > 0) 
        {
            input();
            solve();
        }
    }
    
    public static void main(String[] args) 
    {
        // TODO code application logic here
       new Thread(new Main()).start();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值