HDU 1880

魔咒词典

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13779    Accepted Submission(s): 3335


Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
 

Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
 

Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
 

Sample Input
  
  
[expelliarmus] the disarming charm [rictusempra] send a jet of silver light to hit the enemy [tarantallegra] control the movement of one's legs [serpensortia] shoot a snake out of the end of one's wand [lumos] light the wand [obliviate] the memory charm [expecto patronum] send a Patronus to the dementors [accio] the summoning charm @END@ 4 [lumos] the summoning charm [arha] take me to the sky
 

Sample Output
  
  
light the wand accio what? what?
 

Author
ZJU
 

这道题用map做的话会显示内存超限等一系列错误,附上一个错误代码

错误代码!!

错误代码!!

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string a,b;
    map<string,string>m;
    map<string,int>n;
    while(cin>>a)
    {
        if(a=="@END@")
            break;
        getchar();
        getline(cin,b);
        m[a]=b;
        m[b]=a;
        n[a]++;
        n[b]++;
    }
    getchar();
    int t;
    string c;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        char x[100];
        gets(x);
        c=x;
        if(n[c]>0)
        {
            if(c[0]=='[')
            {
                cout<<m[c]<<endl;
            }
            else
            {
                string d=m[c];
                int l=d.length();
                for(int i=0;i<l;i++)
                {
                    if(i==0||i==l-1)
                        continue;
                    else
                        cout<<d[i];
                }
                cout<<endl;
            }
        }
        else
        {
            cout<<"what?"<<endl;
        }
    }
    return 0;
}



然后经过别人提醒其实这道题也没那么复杂,就是字符串处理,题目要求5S,所以暴力的话应该也能过的啦。

正确代码

正确代码

正确代码

#include<iostream>
#include<string.h>
#include<cstdio>
using namespace std;
char a[100001][26],b[100001][81];
char ab[81];
int main()
{
    int k;
    int t;
    k=0;
    for(int i=0;;i++)
    {
        for(int j=0;;j++)
        {
            scanf("%c",&a[i][j]);
            if(a[i][j]==']')
                break;
            if(a[i][0]=='@'&&a[i][4]=='@')
                break;
        }
        if(a[i][0]=='@')
            break;
        getchar();
        gets(b[i]);
        k++;
    }
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        int flag=0;
        gets(ab);
        if(ab[0]=='[')
        {
            for(int i=0;i<k;i++)
            {
                if(strcmp(ab,a[i])==0)
                {
                    printf("%s\n",b[i]);
                    flag=1;
                    break;
                }
            }
            if(flag==0)
                printf("what?\n");
        }
        else
        {
            for(int i=0;i<k;i++)
            {
                if(strcmp(ab,b[i])==0)
                {
                    for(int j=1;j<strlen(a[i])-1;j++)
                    {
                        printf("%c",a[i][j]);
                    }
                    printf("\n");
                    flag =1;
                    break;
                }
            }
            if(flag==0)
                printf("what?\n");
        }
    }
    return 0;
}

定义的数组一定要够大,不够大就会提示时间超限(具体原因我也不知道)。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值