HDU2421 Party at Hali-Bula 树形DP

Party at Hali-Bula

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1948    Accepted Submission(s): 680


Problem Description
Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.
 

Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.
 

Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.
 

Sample Input
  
  
6 Jason Jack Jason Joe Jack Jill Jason John Jack Jim Jill 2 Ming Cho Ming 0
 

Sample Output
  
  
4 Yes 1 No
 


题意:参加party,员工不与直接上司共同出席,问最多能有多少人参加,如果最多的有多种情况输出NO,否则输出YES


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <queue>
#define N 222

using namespace std;
int n;

vector<vector<int> >G;

int dp[222][2];//第二维0表示不参加,1表示参加
int dup[222][2];//  第二维0表示不止一种,1表示只有一种
char str[N],str1[N],str2[N];

void dfs(int node)
{
    dp[node][0]=0;
    dp[node][1]=1;
    dup[node][0]=1;
    dup[node][1]=1;

    for(int i=0;i<(G[node].size());i++)
    {
        int v=G[node][i];
        dfs(v);

        dp[node][0]+=max(dp[v][1],dp[v][0]);
        dp[node][1]+=dp[v][0];

        if(dup[v][0]==0) dup[node][1]=0;
        if(dp[v][1]>dp[v][0]&&dup[v][1]==0) dup[node][0]=0;
        else if(dp[v][1]<dp[v][0]&&dup[v][0]==0) dup[node][0]=0;
        else if(dp[v][1]==dp[v][0]) dup[node][0]=0;



    }
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
         int num=0;
        G.clear();
        G.resize(222);
        map<string,int>name;//设置成全局就RE。。

        scanf("%s",str);

        name[str]=++num;
        memset(dp,0,sizeof dp);
        memset(dup,0,sizeof dup);

        for(int i=1;i<n;i++)
        {
            scanf("%s%s",str1,str2);
            if(name.find(str1)==name.end()) name[str1]=++num;
            if(name.find(str2)==name.end()) name[str2]=++num;
            G[name[str2]].push_back(name[str1]);
        }

        dfs(1);

        if(dp[1][0]>dp[1][1]&&dup[1][0]==1) 
        cout<<dp[1][0]<<" Yes"<<endl;
        
        else if(dp[1][0]<dp[1][1]&&dup[1][1]==1) 
        cout<<dp[1][1]<<" Yes"<<endl;
        
        else 
        cout<<max(dp[1][0],dp[1][1])<<" No"<<endl;
    }
    return 0;
}


















  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值