HDU2421Deciphering Password(数论&质因数分解)

Deciphering Password

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Problem Description
Xiaoming has just come up with a new way for encryption, by calculating the key from a publicly viewable number in the following way:
Let the public key N = A B, where 1 <= A, B <= 1000000, and a 0, a 1, a 2, …, a k-1 be the factors of N, then the private key M is calculated by summing the cube of number of factors of all ais. For example, if A is 2 and B is 3, then N = A B = 8, a 0 = 1, a 1 = 2, a 2 = 4, a 3 = 8, so the value of M is 1 + 8 + 27 + 64 = 100.
However, contrary to what Xiaoming believes, this encryption scheme is extremely vulnerable. Can you write a program to prove it?
 

Input
There are multiple test cases in the input file. Each test case starts with two integers A, and B. (1 <= A, B <= 1000000). Input ends with End-of-File.
Note: There are about 50000 test cases in the input file. Please optimize your algorithm to ensure that it can finish within the given time limit.
 

Output
For each test case, output the value of M (mod 10007) in the format as indicated in the sample output.
 

Sample Input
  
  
2 2 1 1 4 7
 

Sample Output
  
  
Case 1: 36 Case 2: 1 Case 3: 4393
 
题意:给定a,b,a^b所有因子的因子个数的立方和.
如:
a=2,b=3; a^b=8;
8的因子有1,2,4,8;
所以ans=1+8+27+64.

设n=a1^p1*a2^p2*......*an^pn

则n的任意一个约数都具有a1^b1*a2^b2*......*an^bn(0<=bi<=pi)的形式。也就是说分别从1、ai、ai^2、ai^3。。。。ai^pi抽出一个相乘,而(1+a1+....a1^p1)*......*(1+an+....an^pn)恰有这种形式。ai^pi的因子为ai^i,其约数的个数为i+1.所以ai^pi的因子的约数个数的立方和为1+2^3+...+(pi+1)^3=(pi+1)^2*(pi+2)^2/4。

对于此题来说当a为质数时,那么答案就是(b+1)^2*(b+2)^2/4;a不是质数时,我们分解质因数,就是上面所讲的解法了。

/*********************************************************************
	> File Name: HDU2421.cpp
	> Author: Tailless
	> Mail: xihuanjin1@gmail.com
 ********************************************************************/

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <vector>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <list>
#include <map>
#include <set>
#define C 0.57721566490153286060651209
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

using namespace std;

typedef long long LL;
const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);

const int maxn=1000009;
const int maxm=1000009;

bool vis[maxn];
int prime[maxn];
int num=0;
LL ans=1;
void init()
{
	for(int i=2;i<=maxn;i++)
	{
		if(!vis[i])
			prime[num++]=i;
		for(int j=0;j<num&&i*prime[j]<=maxn;j++)
		{
			vis[i*prime[j]]=true;
			if(i%prime[j]==0)
				break;
		}
	}
}

int main()
{
	init();
	int cas=1;
	int a,b;
	while(~scanf("%d%d",&a,&b))
	{
		ans=1;
		int k=0;
		while(a>1)
		{
			int j=0;
			if(!vis[a])
			{
				j=b;
				ans=(ans*(j+1)*(j+2)/2)%10007;
				ans=(ans*(j+1)*(j+2)/2)%10007;
				break;
			}
			while(a%prime[k]==0)
			{
				a/=prime[k];
				j++;
			}
			j*=b;
			ans=(ans*(j+1)*(j+2)/2)%10007;
			ans=(ans*(j+1)*(j+2)/2)%10007;
			k++;
		}
		printf("Case %d: %lld\n",cas++,ans);
	}
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值