Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10 1 3 6 9 0 8 5 7 4 2
Sample Output
16
题意:从初始的数组开始,每次把第一个加到最后一个,求逆序数,共求出n个逆序数,找出最小值
对每种情况都求逆序数,可以每次都归并排序,或树状数组,或线段树,也可以由上一个的逆序数推出;
a[1] , a[2] , a[3] 。。。a[n],将a[1]放到最后,然后将a[2]放到最后,可以找到规律,将首个a[i]放到最后时,逆序数增加了 a[i]之前比a[i]大的,增加a[i]之后比a[i]大的,减小了a[i]之前比a[i]小的,减小了a[i]之后比a[i]小的,又因为每次给出的数n个数在0到n,且都不同,最后得出 逆序数会增加 n-a[i]个,减少a[i]-1个
思路:
1:逆序数:i<j,ai>aj,如:4 5 3 2 1,
4的逆序数个数0
5的逆序数个数0
3的逆序数4 5,个数2
2的你叙述4 5 3,个数3
1的逆序数4 5 3 2,个数4
2:离散化的方法
每加入一个数,该位置对应的sum标记1,并更新。
在该位置之后的到n的范围内的1的个数就是这个数的逆序数。
如加入4,逆序数0
加入5,逆序数0
加入3,位置4,5均有1,逆序数为2
加入2,位置3,4,5均有1,逆序数为3
加入1,位置2 3 4 5,逆序数为4.
3最小逆序数对
先求出第一个序列的逆序数,然后用很巧妙的办法求下一个序列的逆序数,直到全部求出;
序列 4 5 2 1 3 6 ,此序列的逆序数为7,它等到的下一个序列为 5 2 1 3 6 4
看这个新序列的产生过程,首部删除4,尾部添加4
删除4,必然会使得这个序列的逆序数减少(4-1)个,因为4前面必定有4-1个数小于4
添加4,必然会使得这个序列的逆序数增加(6-4)个,因为4后面必定有6-4个数大于4
由此推出公式,假设移动的数为m,序列的逆序数=上一序列逆序数-(m-1)+(N-m)
对每种情况都求逆序数,可以每次都归并排序,或树状数组,或线段树,也可以由上一个的逆序数推出;
a[1] , a[2] , a[3] 。。。a[n],将a[1]放到最后,然后将a[2]放到最后,可以找到规律,将首个a[i]放到最后时,逆序数增加了 a[i]之前比a[i]大的,增加a[i]之后比a[i]大的,减小了a[i]之前比a[i]小的,减小了a[i]之后比a[i]小的,又因为每次给出的数n个数在0到n,且都不同,最后得出 逆序数会增加 n-a[i]个,减少a[i]-1个
思路:
1:逆序数:i<j,ai>aj,如:4 5 3 2 1,
4的逆序数个数0
5的逆序数个数0
3的逆序数4 5,个数2
2的你叙述4 5 3,个数3
1的逆序数4 5 3 2,个数4
2:离散化的方法
每加入一个数,该位置对应的sum标记1,并更新。
在该位置之后的到n的范围内的1的个数就是这个数的逆序数。
如加入4,逆序数0
加入5,逆序数0
加入3,位置4,5均有1,逆序数为2
加入2,位置3,4,5均有1,逆序数为3
加入1,位置2 3 4 5,逆序数为4.
3最小逆序数对
先求出第一个序列的逆序数,然后用很巧妙的办法求下一个序列的逆序数,直到全部求出;
序列 4 5 2 1 3 6 ,此序列的逆序数为7,它等到的下一个序列为 5 2 1 3 6 4
看这个新序列的产生过程,首部删除4,尾部添加4
删除4,必然会使得这个序列的逆序数减少(4-1)个,因为4前面必定有4-1个数小于4
添加4,必然会使得这个序列的逆序数增加(6-4)个,因为4后面必定有6-4个数大于4
由此推出公式,假设移动的数为m,序列的逆序数=上一序列逆序数-(m-1)+(N-m)
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int tre[200000];
int a[5010];
void update(int num,int le,int ri,int node)
{
if(le==ri&&le==node)
{
tre[num]++;
return ;
}
else
{
int mid=(le+ri)/2;
if(node<=mid)
update(num*2,le,mid,node);
else
update(num*2+1,mid+1,ri,node);
tre[num]=tre[num*2]+tre[num*2+1];
}
}
int query(int num,int le,int ri,int x,int y)
{
if(x<=le&&y>=ri)
return tre[num];
int ans=0;
int mid=(le+ri)/2;
if(x<=mid)
ans+=query(num*2,le,mid,x,y);
if(mid+1<=ri)
ans+=query(num*2+1,mid+1,ri,x,y);
return ans;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int mmin=0;
memset(a,0,sizeof a);
memset(tre,0,sizeof tre);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
a[i]++;
mmin+=query(1,1,n,a[i],n);
update(1,1,n,a[i]);
}
int sum=mmin;
for(int i=1;i<n;i++)
{
sum=sum+1+n-2*a[i];
if(sum<mmin)
mmin=sum;
}
printf("%d\n",mmin);
}
return 0;
}