nyoj——675 Sinking Ship

Sinking Ship

时间限制: 2000 ms  |  内存限制: 65535 KB
难度: 1
描述
 The ship crashed into a reef and is sinking. Now the entire crew must be evacuated. All n crew members have already lined up in a row (for convenience let's label them all from left to right with positive integers from 1 to n) and await further instructions. However, one should evacuate the crew properly, in a strict order. Specifically:
The first crew members to leave the ship are rats. Then women and children (both groups have the same priority) leave the ship. After that all men are evacuated from the ship. The captain leaves the sinking ship last.
If we cannot determine exactly who should leave the ship first for any two members of the crew by the rules from the previous paragraph, then the one who stands to the left in the line leaves the ship first (or in other words, the one whose number in the line is less).
For each crew member we know his status as a crew member, and also his name. All crew members have different names. Determine the order in which to evacuate the crew.
输入
The first line contains an integer n, which is the number of people in the crew (1 ≤ n ≤ 100). Then follow n lines. The i-th of those lines contains two words — the name of the crew member who is i-th in line, and his status on the ship. The words are separated by exactly one space. There are no other spaces in the line. The names consist of Latin letters, the first letter is uppercase, the rest are lowercase. The length of any name is from 1 to 10 characters. The status can have the following values: rat for a rat, woman for a woman, childfor a child, man for a man, captain for the captain. The crew contains exactly one captain.
输出
Print n lines. The i-th of them should contain the name of the crew member who must be the i-th one to leave the ship.
样例输入
6
Jack captain
Alice woman
Charlie man
Teddy rat
Bob child
Julia woman
样例输出
Teddy
Alice
Bob
Julia
Charlie
Jack
来源

NYIST第一届校赛(专业组)


题意:船将要下沉,为了使船上的人安全逃生,逃离人员的顺序如下:第一批逃跑的是rat,妇女和孩子的优先级相同,所以第二批逃跑的人为woman和child,第三批逃跑的人为man,最后一批为船上captain。输入的情况是前面为人名,空格后面为属于哪一类。

由于数据较少,所以在这里对几种情况分开讨论,用三维数组尝试了下,直接水过了。


代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N(n,m) memset(n,m,sizeof(n));
#define M(n,m,k) for(int n=m;n<k;n++)

using namespace std;


char a[101][2][11];


int main()
{
    int t;
    while(scanf("%d",&t)!=EOF)
    {
        N(a,0)
        for(int i=0; i<t; i++)
        {
            cin>>a[i][0]>>a[i][1];
        }
        for(int i=0; i<t; i++)
            if(strcmp(a[i][1],"rat")==0)
            {
                a[i][1][0]='^';
                printf("%s\n",a[i][0]);
            }
        for(int i=0; i<t; i++)
            if(a[i][1][0]!='^')
                if(strcmp(a[i][1],"woman")==0||strcmp(a[i][1],"child")==0)
                {
                    a[i][1][0]='^';
                    printf("%s\n",a[i][0]);
                }
        for(int i=0; i<t; i++)
            if(a[i][1][0]!='^')
                if(strcmp(a[i][1],"man")==0)
                {
                    a[i][1][0]='^';
                    printf("%s\n",a[i][0]);
                }
        for(int i=0; i<t; i++)
            if(a[i][1][0]!='^')
                printf("%s\n",a[i][0]);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值