POJ ——2386 Lake Counting(DFS)

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24697 Accepted: 12475

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.


简单DFS


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<math.h>
#include<string.h>
#define M(i,n,m) for(int i = n;i < m;i ++)
#define N(n,m) memset(n,m,sizeof(n));
const int MAX = 111;
using namespace std;
int s[8][2] = {{0,1},{1,0},{0,-1},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
char a[MAX][MAX];
int b[MAX][MAX],n,m;

void dfs(int x,int y)
{
    b[x][y] = 1;
    M(i,0,8)
    {
        int t1 = x + s[i][0];
        int t2 = y + s[i][1];
        if(t1 >= 0 && t1 < n && t2 >= 0 && t2 < m && a[t1][t2] == 'W' && !b[t1][t2])
        {
            b[t1][t2] = 1;
            dfs(t1,t2);
        }
    }
    return;
}

int main()
{
    int sum;
    while(~scanf("%d%d",&n,&m))
    {
        if(!n && !m)
            break;
        N(b,0)
        sum = 0;
        M(i,0,n)
        scanf("%s",a[i]);
        M(i,0,n)
        M(j,0,m)
        if(a[i][j] == 'W' && !b[i][j])
        {
            sum ++;
            dfs(i,j);
        }
        printf("%d\n",sum);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值