POJ —— 3617 Best Cow Line

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14395 Accepted: 4096

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

贪心思想:

不断从数组的开头和末尾中较小的一个字符输出;

这样的话忘记了讨论 若开头和末尾相同时的情况,所以,进一步优化的算法如下:

按照字典序比较a数组和a数组反转后的字符串a';

如果a较小,就从a的开头取出一个字符,输出;

如果a'较小,就从a的末尾取出一个字符输出;


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<math.h>
#include<queue>
#define M(i,n,m) for(int i = n;i < m;i ++)
#define N(n,m) memset(n,m,sizeof(n));
const int MAX = 2002;
using namespace std;
char a[MAX];
int n;

void solve()
{
    int count = 0;      ///对输出时的空行进行讨论
    int x = 0,y = n - 1;
    while(x <= y)   ///x = y 表明还剩余这一个元素
    {
        bool left = false;
        for(int i = 0; x + i <= y; i ++)  ///用x + i <= y表示可能此时已经有x个或者y个数输出,对此区域的数不需要再讨论
        {
            ///若相同的话,再比较下面的字符是否相同,直到不相同输出较小的一个
            if(a[x + i] < a[y-i])
            {
                left = true;
                break;
            }
            else if(a[x + i] > a[y - i])
            {
                left = false;
                break;
            }
        }
        if(left)
        {
            printf("%c",a[x ++]);
            count ++;
            if(count % 80 == 0)
                printf("\n");
        }
        else
        {
            printf("%c",a[y --]);
            count ++;
            if(count % 80 == 0)
                printf("\n");
        }
    }
    printf("\n");
    return ;
}

int main()
{
    while(cin>>n)
    {
        M(i,0,n)
        cin>>a[i];
        solve();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值