nyoj708

ones

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given a positive integer N (0<=N<=10000), you are to find an expression equals to N using only 1,+,*,(,). 1 should not appear continuously, i.e. 11+1 is not allowed.
输入
There are multiple test cases. Each case contains only one line containing a integer N
输出
For each case, output the minimal number of 1s you need to get N.
样例输入
2
10
样例输出
2
7
上传者

TC_胡仁东

/*
题意:对于任意给定的一个数字n,找出最小需要多少个1通过加和乘组合得到
思路:判断一个数是否是素数,如果是,则只能通过前面的相邻数进行更新。
不是,则这个数可以通过除去1和它本身的其它数整除得到,则可以通过此种方式更新。
状态转移方程:dp[i] = min(dp[i-1]+1(是素数),dp[j]+dp[i/j](不是素数));
不是素数的时候也需要对是素数的dp[i-1]+1进行比较
*/
#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>

using namespace std;
int dp[10010] = {0,1,2,3,4,5};

void Init()
{
    for(int i = 6; i <= 10000; i ++)
    {
        dp[i] = dp[i-1] + 1;///先通过前面的进行更新
        for(int j = 1; j <= i; j ++)///对i进行更新
            if(i % j == 0)///判断是否可以用乘积表示,可以的话,也进行更新
                dp[i] = min(dp[i],dp[j] + dp[i/j]);
    }
}

int main()
{
    Init();
    int n;
    while(~scanf("%d",&n))
    {
        printf("%d\n",dp[n]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值