NYOJ 题目708 ones(dp水)

ones

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given a positive integer N (0<=N<=10000), you are to find an expression equals to N using only 1,+,*,(,). 1 should not appear continuously, i.e. 11+1 is not allowed.
输入
There are multiple test cases. Each case contains only one line containing a integer N
输出
For each case, output the minimal number of 1s you need to get N.
样例输入
2
10
样例输出
2
7
上传者
TC_胡仁东
ac代码
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
#define min(a,b) (a>b?b:a)
long long dp[10001];
void fun()
{
	int i,j,k;
	dp[1]=1;
	for(i=2;i<10001;i++)
	{
		dp[i]=INF;
		for(j=i-1;j>0;j--)
		{
			dp[i]=min(dp[i-j]+dp[j],dp[i]);
			if(i%j==0)
				dp[i]=min(dp[i],dp[j]+dp[i/j]);
		}
	}
}
int main()
{
	int n;
	fun();
	while(scanf("%d",&n)!=EOF)
		printf("%lld\n",dp[n]);
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值