HDU 5024 Wang Xifeng's Little Plot 暴搜

题目描述:

Problem Description
《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao’s wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao.

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn’t want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu’s room and Baochai’s room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai’s room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a “redist”) are always arguing about the location of Baoyu’s room and Baochai’s room. Now you can solve this big problem and then become a great redist.

Input
The map of Da Guan Yuan is represented by a matrix of characters ‘.’ and ‘#’. A ‘.’ stands for a part of road, and a ‘#’ stands for other things which one cannot step onto. When standing on a ‘.’, one can go to adjacent ‘.’s through 8 directions: north, north-west, west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N ( 0 < N <=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.

Output
For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai’s rooms. A road’s length is the number of ‘.’s it includes. It’s guaranteed that for any test case, the maximum length is at least 2.

Sample Input

3
#.#
##.
..#
3
...
##.
..#
3
...
###
..#
3
...
##.
...
0

Sample Output

3
4
3
5

题目分析:

题目大意就是在一个n*n的图中,’.’表示能够通行,’#’表示不能。找两个’.’使它们之间行走距离最长(路线包含’.’的个数为行走距离)。可以通过上下左右和左上左下右上右下总共八个方向行走。其中要求最多只能有一次转弯,并且这个转弯必须为90度角转弯。
由于n只有100,所以暴搜完全可以。其中搜索八个方向中,分成两类,一类就是上下左右,另一类是左上左下右上右下,因为只有将它们区分开来才能满足转弯为90度的条件,对于每一个点,都记录下这个点能够向这两类方向伸展的最大长度,然后每一类方向有四个方向,将其中最大的两个值相加记录(相当于也满足了最多只能转一次弯的条件)找最大值就完了。

代码如下:

#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>

using namespace std;

const int maxn=110;
char mp[maxn][maxn];
int dir[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
int n,ans;

void solve(int x,int y,int t)
{
    int count[4];
    memset(count,0,sizeof(count));
    for(int i=0+t; i<4+t; i++)
    {
        int xx=x,yy=y;
        while(1)
        {
            xx+=dir[i][0];
            yy+=dir[i][1];
            if (mp[xx][yy]=='.' && xx<=n && yy<=n && xx>=1 && yy>=1)
            {
                count[i-t]++;
            }
            else break;
        }
    }
    sort(count,count+4);
    ans=max(ans,count[2]+count[3]);
}

int main()
{
    while(scanf("%d",&n)!=-1 && (n!=0))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%s",mp[i]+1);
        }
        ans=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if (mp[i][j]=='.')
                {
                    solve(i,j,0);
                    solve(i,j,4);
                }
            }
        }
        printf("%d\n",ans+1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值