HDU 5883 The Best Path 欧拉图

题目描述:

Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are N lakes, and M rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number (a1,a2,…,an) for each lake. If the path she finds is P0→P1→…→Pt, the lucky number of this trip would be aP0XORaP1XOR…XORaPt. She want to make this number as large as possible. Can you help her?

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.

For each test case, in the first line there are two positive integers N (N≤100000) and M (M≤500000), as described above. The i-th line of the next N lines contains an integer ai(∀i,0≤ai≤10000) representing the number of the i-th lake.

The i-th line of the next M lines contains two integers ui and vi representing the i-th river between the ui-th lake and vi-th lake. It is possible that ui=vi.

Output
For each test cases, output the largest lucky number. If it dose not have any path, output “Impossible”.

Sample Input

2
3 2
3
4
5
1 2
2 3
4 3
1
2
3
4
1 2
2 3
2 4

Sample Output

2
Impossible

Source
2016 ACM/ICPC Asia Regional Qingdao Online

题目分析:

一个无向图,n个点,m条边,要求将所有边都遍历且仅遍历一次。n个点有其点权,每一次到达这个点将这个值进行异或,求最大的异或值。
由于异或运算是满足交换律的,所以其实只需要计算这个点的权进行运算的次数就可以,满足这个值最大。
首先,这个图必须满足欧拉通路或欧拉回路,否则没办法将所有边都只遍历一次。也就是计算他们的度就可以。然后通路和回路分别讨论。
如果是回路,选择一个点是起点和终点,也就是异或偶数次,找这个最大值就可。
如果是通路,先计算两个奇点计算次数,然后偶度点分情况讨论是经过奇数次还是偶数次。

代码如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;

const int N = 1e5 + 5;
int n, m, d[N];

int solve()
{
    int cnt = 0;
    int f=0;
    bool flag=true;
    for(int i = 1; i <= n; i++)
    {
        if(d[i] % 2) f++;
        if (d[i]==0) flag=false;
    }
    if (!flag) return 0;
    //if (f!=2 && f!=0) return false;
    //return true;
    if (f==2) return 1;
    else if (f==0) return 2;
    return 0;
}

int T;
int w[N];
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(d,0,sizeof(d));
        int x, y;
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&w[i]);
        }
        for(int i = 0; i < m; i ++)
        {
            scanf("%d %d", &x, &y);
            //Union(x, y);
            d[x] ++;
            d[y] ++;
        }
//        for(int i=1; i<=n; i++)
//        {
//            printf("%d ",d[i]);
//        }
//        printf("\n");
        if(solve()==1)//tonglu
        {
            for(int i=1; i<=n; i++)
            {
                int tmp;
                if(d[i]%2)
                {
                    ans=ans^w[i];
                    d[i]--;
                }
                tmp=d[i]/2;
                if(tmp%2) ans=ans^w[i];
            }
            printf("%d\n",ans);
        }
        else if (solve()==2)//huilu
        {
            for(int i=1; i<=n; i++)
            {
                int tmp=d[i]/2;
                if(tmp%2) ans=ans^w[i];
            }
            ans=ans^w[1];
            for(int i=2; i<=n; i++)
            {
                ans=max(ans,ans^w[i]);
            }
            printf("%d\n",ans);
        }
        else puts("Impossible");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值