poj 2155 Matrix 二维树状数组

本文通过一个具体的编程问题,介绍了如何使用二维树状数组来高效处理矩阵上的操作和查询。文章详细解释了更新和查询的操作,并附上了实现代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

#include<cstdio>
#include<string>
#include<iostream>
#include<string.h>
using namespace std;
int c[1005][1005],n;
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int y,int k )
{
    for(int i=x; i<=n; i+=lowbit(i))
        for(int j=y; j<=n; j+=lowbit(j))
        {
            c[i][j]+=k;
        }
}
int sum(int x,int y)
{
    int ans=0;
    for(int i=x; i>0; i-=lowbit(i))
        for(int j=y; j>0; j-=lowbit(j))
            ans+=c[i][j];
    return ans;
}
int main()
{
    int t,m,x1,x2,y1,y2;
    char g[100];
    scanf("%d",&t);
    while(t--)
    {
      memset(c,0,sizeof(c));
        scanf("%d %d",&n,&m);
        for(int i=1; i<=m; i++)
        {
            scanf("%s",g);
            if(g[0]=='C')
            {
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                getchar();
                update(x1,y1,1);
                update(x1,y2+1,1);
                update(x2+1,y1,1);
                update(x2+1,y2+1,1);
            }
            else
            {
                scanf("%d %d",&x1,&y1);
                getchar();
                printf("%d\n",sum(x1,y1)%2);
            }
        }
        printf("\n");
    }
    return 0;
}


今天初步学习树状数组,虽然还有很多不懂,但这也是一个进步吧

下面是转载的一位大牛的博客

楼教主出的二维树状数组。

 

给出矩阵左上角和右下角坐标,矩阵里的元素 1变0 ,0 变1,然后给出询问,问某个点是多少。

 

纠结好久了,一直没什么好思路,看discuss说四个角神马的,我搜了下,理解了,树状数组里记录该点的变幻次数,或者直接%2也行。

 

查询的时候Getsum得到的是该点在所有区间的总变幻次数,最后%2就是结果。

 

建图的时候死活想不通,杂四个点的坐标是那个 = =。。。刚才协会开会了,在路上想通了,我想的0,0坐标是类似坐标轴的那种,在左下角。。。而矩阵的0 0 应该是在左上角。。这样,什么都通了 = =。。。

 

还有,更新的时候有的减1了,死循环了,发现错误了,树状数组里是不能使用下标为1的,所以更新的时候把下标都加一即可。

 

实验了下,%2和&1速度一样。。。

 

提供坐标的图。。

 

我见另一种做法,见 http://3214668848.blog.163.com/blog/static/48764919201052484413539/

 

就是原来的Updata改成Getsum。。。Getsum改成Updata。只不过每个坐标不用++了。

 

 

 

这题我还是有点迷茫的。刚才上机组课想了下,经过我画图以及认真分析(//害羞)代码,终于理解了。。。继续画图先。。

 

 

#include <queue>
#include <stack>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <limits.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAX = 1010;
int c[MAX][MAX];
int n;
int Lowbit(int x)
{
	return x & (-x);
}
void Updata(int x,int y)
{
	int i,k;
	for(i=x; i<=n; i+=Lowbit(i))
		for(k=y; k<=n; k+=Lowbit(k))
			c[i][k]++;
}
int Get(int x,int y)
{
	int i,k,sum = 0;
	for(i=x; i>0; i-=Lowbit(i))
		for(k=y; k>0; k-=Lowbit(k))
			sum += c[i][k];
	return sum;
}
int main()
{
	int ncases,m;
	int x1,y1,x2,y2;
	char ch[2];
	scanf("%d",&ncases);
	while( ncases-- )
	{
		memset(c,0,sizeof(c));
		scanf("%d%d",&n,&m);
		while( m-- )
		{
			scanf("%s",ch);
			if( ch[0] == 'C' )
			{
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				x1++; y1++; x2++; y2++;
				Updata(x2,y2);
				Updata(x1-1,y1-1);
				Updata(x1-1,y2);
				Updata(x2,y1-1);
			}
			else
			{
				scanf("%d%d",&x1,&y1);
				printf("%d/n",Get(x1,y1)%2);
			}
		}
		printf("/n");
	}
return 0;
}


内容概要:本文档提供了三种神经网络控制器(NNPC、MRC和NARMA-L2)在机器人手臂模型上性能比较的MATLAB实现代码及详细解释。首先初始化工作空间并设定仿真参数,包括仿真时间和采样时间等。接着定义了机器人手臂的二阶动力学模型参数,并将其转换为离散时间系统。对于参考信号,可以选择方波或正弦波形式。然后分别实现了三种控制器的具体算法:MRC通过定义参考模型参数并训练神经网络来实现控制;NNPC利用预测模型神经网络并结合优化算法求解控制序列;NARMA-L2则通过两个神经网络分别建模f和g函数,进而实现控制律。最后,对三种控制器进行了性能比较,包括计算均方根误差、最大误差、调节时间等指标,并绘制了响应曲线和跟踪误差曲线。此外,还强调了机器人手臂模型参数的一致性和参考信号设置的规范性,提出了常见问题的解决方案以及性能比较的标准化方法。 适合人群:具备一定编程基础,特别是熟悉MATLAB编程语言的研究人员或工程师,以及对神经网络控制理论有一定了解的技术人员。 使用场景及目标:①理解不同类型的神经网络控制器的工作原理;②掌握在MATLAB中实现这些控制器的方法;③学会如何设置合理的参考信号并保证模型参数的一致性;④能够根据具体的性能指标对比不同控制器的效果,从而选择最适合应用场景的控制器。 其他说明:本文档不仅提供了完整的实验代码,还对每个步骤进行了详细的注释,有助于读者更好地理解每段代码的功能。同时,针对可能出现的问题给出了相应的解决办法,确保实验结果的有效性和可靠性。为了使性能比较更加公平合理,文档还介绍了标准化的测试流程和评估标准,这对于进一步研究和应用具有重要的指导意义。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值