hdu 3315 My Brute 网络流

Description

Seaco is a beautiful girl and likes play a game called “My Brute”. Before Valentine’s Day, starvae and xingxing ask seaco if she wants to spend the Valentine’s Day with them, but seaco only can spend it with one of them. It’s hard to choose from the two excellent boys. So there will be a competition between starvae and xingxing. The competition is like the game “My Brute”. 


Now starvae have n brutes named from S1 to Sn and xingxing’s brutes are named from X1 to Xn. A competition consists of n games. At the beginning, starvae's brute Si must versus xingxing’s brute Xi. But it’s hard for starvae to win the competition, so starvae can change his brutes’ order to win more games. For the starvae’s brute Si, if it wins the game, starvae can get Vi scores, but if it loses the game, starvae will lose Vi scores. Before the competition, starvae’s score is 0. Each brute can only play one game. After n games, if starvae’s score is larger than 0, we say starvae win the competition, otherwise starvae lose it. 

It’s your time to help starvae change the brutes’ order to make starvae’s final score be the largest. If there are multiple orders, you should choose the one whose order changes the least from the original one. The original order is S1, S2, S3 … Sn-1, Sn, while the final order is up to you. 

For starvae’s brute Si (maybe this brute is not the original brute Si, it is the ith brute after you ordered them) and xingxing’s brute Xi, at first Si has Hi HP and Xi has Pi HP, Si’s damage is Ai and Xi’s is Bi, in other words, if Si attacks, Xi will lose Ai HP and if Xi attacks, Si will lose Bi HP, Si attacks first, then it’s Xi’s turn, then Si… until one of them’s HP is less than 0 or equal to 0, that, it lose the game, and the other win the game. 

Come on, starvae’s happiness is in your hand!
 

Input

First line is a number n. (1<=n<=90) Then follows a line with n numbers mean V1 to Vn. (0<Vi<1000) Then follows a line with n numbers mean H1 to Hn. (1<=Hi<=100)Then follows a line with n numbers mean P1 to Pn. (1<=Pi<=100) Then follows a line with n numbers mean A1 to An.(1<=Ai<=50) Then follows a line with n numbers mean B1 to Bn. (1<=Bi<=50) A zero signals the end of input and this test case is not to be processed.
 

Output

For each test case, if starvae can win the competition, print the largest score starvae can get, and then follow a real percentage means the similarity between the original order and the final order you had changed, round it to three digits after the decimal point. If starvae can’t win the competition after changing the order, please just print “Oh, I lose my dear seaco!” Maybe the sample can help you get it.
 

Sample Input

       
       
3 4 5 6 6 8 10 12 14 16 7 7 6 7 3 5 3 4 5 6 6 8 10 12 14 16 5 5 5 5 5 5 0
 

Sample Output

       
       
7 33.333% Oh, I lose my dear seaco!
 
读题花费了好长时间,后来发现第二个小知识点不会,看了一下别人的才猛然想起以前鹏哥用过这种方法。。。
不说了都是泪啊。。同样的代码交不同的次数有不同的结果。。。。
题意:


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
#define INF 0x3f3f3f3f

using namespace std;
int A[100],B[100],V[100],H[100],P[100];
int head[3000],vis[3000],dis[3000],pre[3000];
int cnt,s,T;
struct node
{
    int u,v,w,f,next;
} edge[30000];
void add(int u,int v,int w,int f)
{
    edge[cnt].u=u;
    edge[cnt].v=v;
    edge[cnt].w=w;
    edge[cnt].f=f;
    edge[cnt].next=head[u];
    head[u]=cnt++;

    edge[cnt].u=v;
    edge[cnt].v=u;
    edge[cnt].w=0;
    edge[cnt].f=-f;
    edge[cnt].next=head[v];
    head[v]=cnt++;
}
int SPFA()
{
    int i;
    memset(pre,-1,sizeof(pre));
    memset(vis,0,sizeof(vis));
    for(i=0; i<=T; i++)
        dis[i]=-INF;
    queue<int>q;
    dis[s]=0;
    vis[s]=1;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        i=head[u];
        vis[u]=0;
        while(i!=-1)
        {
            if(edge[i].w>0&&dis[edge[i].v]<dis[u]+edge[i].f)
            {
                dis[edge[i].v]=dis[u]+edge[i].f;
                pre[edge[i].v]=i;
                if(!vis[edge[i].v])
                {
                    vis[edge[i].v]=1;
                    q.push(edge[i].v);
                }
            }
            i=edge[i].next;
        }
    }
    if(pre[T]==-1)
        return 0;
    return 1;
}
int MincostMaxFlow()
{
    int ans=0;
    while(SPFA())
    {
        int maxl=INF;
        int p=pre[T];
        while(p!=-1)
        {
            maxl=min(maxl,edge[p].w);
            p=pre[edge[p].u];
        }
        p=pre[T];
        while(p!=-1)
        {
            edge[p].w-=maxl;
            edge[p^1].w+=maxl;

            p=pre[edge[p].u];
        }
        ans+=maxl*dis[T];
    }
    return ans;
}
int win(int i,int j)
{
    int x,y;
    if(P[j]%A[i]==0)
        x=P[j]/A[i];
    else
        x=P[j]/A[i]+1;
    if(H[i]%B[j]==0)
        y=H[i]/B[j];
    else
        y=H[i]/B[j]+1;
    if(x<=y)
        return 1;
    else
        return 0;
}
int main()
{
    int n,i,j;
    while(~scanf("%d",&n)&&n)
    {
        cnt=0;
        memset(head,-1,sizeof(head));
        for(i=1;i<=n;i++)
            scanf("%d",&V[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&H[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&P[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&A[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&B[i]);
            s=0,T=2*n+1;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(win(i,j))
                {
                    if(i==j)
                        add(i,n+j,1,V[i]*100+1);
                    else
                        add(i,n+j,1,V[i]*100);
                }
                else
                {
                    if(i==j)
                        add(i,n+j,1,-V[i]*100+1);
                    else
                        add(i,n+j,1,-V[i]*100);
                }
            }
        }
        for(i=1;i<=n;i++)
        {
            add(0,i,1,0);
            add(n+i,T,1,0);
        }
        int res=MincostMaxFlow();
        if(res/100<=0)
            printf("Oh, I lose my dear seaco!\n");
        else
            printf("%d %.3f%%\n",res/100,100.0*(res%100)/n);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值