poj Sorting It All Out 托普排序

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<string.h>
using namespace std;
struct node
{
    int v,next;
} edge[200000];
int n,m,cnt,head[20000],rudu[2000];
void add(int u,int v)
{
    edge[cnt].v=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
int sh[20000],k;
int  topu()
{
    int flag1=0;
    k=0;
    int rd[2000];
    memcpy(rd,rudu,sizeof(rudu));
    queue<int>q;
    for(int i=1; i<=n; i++)
        if(!rd[i])
        {
            q.push(i);
        }
    while(!q.empty())
    {
        int t=q.front();
        sh[k++]=t;
        q.pop();
        if(!q.empty())
        {
            flag1=1;
        }
        for(int pp=head[t]; pp!=-1; pp=edge[pp].next)
        {
            rd[edge[pp].v]--;
            if(rd[edge[pp].v]==0)
                q.push(edge[pp].v);
        }
    }
    if(k!=n)
        return 1;
    else if(flag1==1)
        return 2;
    return 0;
}
int main()
{
    char a,b,c;
    while(scanf("%d %d",&n,&m),n||m)
    {
        getchar();
        memset(head,-1,sizeof(head));
        memset(rudu,0,sizeof(rudu));
        int x=0;
        for(int i=1; i<=m; i++)
        {
            cin>>a>>b>>c;
            int a1,c1;
            a1=a-'A'+1;
            c1=c-'A'+1;
            if(x==0)
            {
                    add(a1,c1);
                    rudu[c1]++;
                int s=topu();
                if(s==0)
                {
                    printf("Sorted sequence determined after %d relations: ",i);
                    for(int j=0; j<k; j++)
                        printf("%c",sh[j]+'A'-1);
                    printf(".\n");
                    x=1;

                }
                else if(s==1)
                {
                    printf("Inconsistency found after %d relations.\n",i);
                     x=1;
                }

            }

        }
        if(!x)
        {
            cout<<"Sorted sequence cannot be determined."<<endl;
        }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值